veniaminsem
?>

Напишите программу для решения с клавиатуры вводится целое 2-значное число , если число положительное то полочить новое число z c перестановкой цифр исходного числа и вывести число z на экран div и mod

Информатика

Ответы

expozition
PascalABC.NET 3.4.2, сборка 1847 от 28.10.2018Внимание! Если программа не работает, обновите версию!

begin

 var n := ReadInteger;

 if n > 0 then

 begin

   var z := 10 * (n mod 10) + n div 10;

   z.Println

 end

end.

Tane4ka2110

В бутылке, стакане, кувшине и банке находится молоко, лимонад, квас и вода. Известно что вода и молоко не в бутылке, а сосуд с лимонадом находится между кувшином и сосудом с квасом, в банке - не лимонад и не вода. Стакан находится около банки и сосуда с молоком. Как распределены эти жидкости по сосудам?

Решение

Бутылка - НЕ вода, НЕ молоко (т.к. вода и молоко не в бутылке

Стакан - НЕ молоко (т.к. Стакан находится около сосуда с молоком)

Кувшин -НЕ лимонад, НЕ квас (т.к. а сосуд с лимонадом находится между кувшином и сосудом с квасом)

Банка - НЕ лимонад, НЕ вода, НЕ молоко (т.к. в банке - не лимонад и не вода., ...около банки и сосуда с молоком), остается, что в банке - квас

т.к. в бутылке и стакане НЕ молоко, значит молоко в кувшине

т.к. в бутылке НЕ вода, значит вода в стакане

значит остается, что в бутылке - лимонад

в банке - квас

молоко в кувшине

вода в стакане

в бутылке - лимонад

drontox1031
// PascalABC.NET 3.0, сборка 1144 от 16.01.2016
begin
  var n:=ReadInteger('n=');
  var a:=ArrRandom(n,-50,50);
  Writeln('Исходный массив'); a.Println;
  var se:=a.Where(x->x mod 3=0);
  if se.Count=0 then
    Writeln('В массиве нет элементов, кратных трем')
  else begin
    var b:=se.Max;
    var i:=0;
    while a[i]<>b do Inc(i);
    if i=n-1 then Writeln('Максимальный элемент - последний')
    else begin
      Writeln('Результирующий массив');
      a[i+1]:=abs(a.Where(x->x<0).Sum); a.Println
      end
    end
end.

Тестовое решение:
n= 15
Исходный массив
-24 -38 15 -33 -40 -18 21 34 20 49 -19 29 29 38 -41
Результирующий массив
-24 -38 15 -33 -40 -18 21 213 20 49 -19 29 29 38 -41

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу для решения с клавиатуры вводится целое 2-значное число , если число положительное то полочить новое число z c перестановкой цифр исходного числа и вывести число z на экран div и mod
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Puschdom
lebedev815
k075ko8
Bolshakova Shigorina
Буянто1346
antoha512
Galiaahmatova4447
Cannabikh
Aleks0091
NIKOLAI
Vetroff-11
mantseva
bochkarevazh
rstas
rada8080