makashi28
?>

Турбо паскаль. написать программу, которая считает количество буквы в строке. допустим букву "а" в любом регистре, строка вводится с клавиатуры. входной файл: предложение выходной файл: количество буквы

Информатика

Ответы

superbalsa

uses Crt;


const

 n=100; { мах длина строки }

 

var

 s:string[n];

 i,k:integer;


begin

 ClrScr;

 Readln(s);

 k:=0;

 for i:=1 to Length(s) do

   if (s[i]='а') or (s[i]='А') then Inc(k);

 Writeln(k);

 ReadKey

end.

proh-dorohova5244

#include <iostream>

using namespace std;

class Building {

private:

 string adress_m;

 int storeyCount_m;

 bool quarantine_m;

public:

 Building(string adress = "", int count = -1) {

  adress_m = adress;

  storeyCount_m = count;

 }

 void addStoreys(int count) {

  storeyCount_m += count;

 }

 void quarantineOn() {

  cout << "Quarantine: on";

  cout << endl;

  quarantine_m = 1;

 }

 void quarantineOff() {

  cout << "Quarantine: off";

  cout << endl;

  quarantine_m = 0;

 }

 void quarantineCheck() {

  cout << "Quarantine: ";

  if(quarantine_m) {

   cout << "on";

   cout << endl;

  } else {

   cout << "off";

   cout << endl;

  }

 }

 string getAdress() {

  return adress_m;

 }

 int getStorey() {

  return storeyCount_m;

 }

};

int main() {

Building build("dirt house", 1);

cout << build.getAdress() << " " << build.getStorey() << " storeys" << " " << endl;

build.quarantineCheck();

build.quarantineOn();

build.addStoreys(2);

cout << build.getAdress() << " " << build.getStorey() << " storeys" << " " << endl;

}

artbogema2016

Эргономика екі грек сөзінен туындайды: эргон , яғни жұмыс және номио , табиғи заңдылықты білдіретін, жұмыс жасау ғылымы мен адамның осы жұмысқа қатыстылығын білдіретін сөз жасау.

Халықаралық Эргономика Ассоциациясы осы техникалық ұғымды қабылдады: «Эргономика ( адам факторлары ) - адам мен басқа да элементтердің өзара әрекеттесуін түсінуге байланысты ғылыми пән, сондай-ақ теориялар, қағидалар, деректер мен әдістерді қолданатын мамандық. адамның әл-ауқатын және жалпы жүйенің өнімділігін оңтайландыру мақсатында жобалау.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Турбо паскаль. написать программу, которая считает количество буквы в строке. допустим букву "а" в любом регистре, строка вводится с клавиатуры. входной файл: предложение выходной файл: количество буквы
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

mirsanm26249
Ruslan Zarekovkin
manager9
Буянто1346
lirene
ii090758
info2990
demakova1969
sidorov9
kolyabelousow4059
Khrimyan1207
nrostovtseva142
alfakurs
A2017
svetavancevich
▲