Larax0819
?>

Даны целые числа x, y, z. если x ≤ y ≤ z, то вывести на экран квадраты этих чисел. если неравенство не выполняется, то вывести на экран наибольшее из чисел. , нужно написать программу на паскале с обязательным использованием условных вложенных операторов.

Информатика

Ответы

Антон-Марина

program xyz;

var

 x, y, z, b: Real;

begin

 Write ('Введите X, Y, Z: ');

 ReadLn (x, y, z);

 if (x <= y) and (y <= z) then begin

   WriteLn ('Квадраты чисел: ', x * x :10 :5, y * y :10 :5, z * z :10 :5)

 end else begin

   if x > y then

     if x > z then

       b := x

     else

       b := z

   else

     if y > z then

       b := y

     else

       b := z;

   WriteLn ('Наибольшее число = ', b :10 :5);

 end;

 ReadLn;

end.

IP1379
#for x in range(4):
#    r.right(1)
#    for y in range(4):
#        r.right(2)
#        r.right(3)

Рассмотрим внутренний цикл. Для каждого у от 1 до 4, робот делает 2 шага вправо, а затем 3 вправо. То есть за весь этот цикл робот сделает (2 + 3) * 4 = 5 * 4 = 20 шагов вправо. Теперь рассмотрим внешний цикл. Для каждого х от 1 до 4, робот делает 1 шаг вправо и ещё 20 шагов вправо за счет того цикла, который мы уже разобрали. Значит всего робот сделает (1 + 20) * 4 = 21 * 4 = 84 шага вправо.
ответ: 84 шага.
Елена Ирина
Var
    N, s, i: Integer;
    s1: real;

begin
    readln(N); {общий ввод для всех задач}
    
    if N < 0 then
        writeln('Задача 1. N=', 0)
    else writeln('Задача 1. N=', N + 4);
    
    s := 0;
    for i := 1 to n do
        s := s + i;
    writeln('Задача 7. 1+2+3+…+N=', s);
    
    write('Задача 9. Последовательность от N до 1 = ');
    for i := n downto 1 do
        write(i, ' ');
    writeln();
    
    s1 := 0;
    for i := 1 to n do
        s1 := s1 + i / 10;
    writeln('Задача 12. 0,1+0,2+0,3+..+N/10=', s1);
    
    write('Задача 13. Последовательность квадратов от 1 до N = ');
    for i := 1 to n do
        write(i * i, ' ');
    writeln();
    
    write('Задача 14. Последовательность первых N нечетных чисел = ');
    for i := 1 to n do
        write(2 * i - 1, ' ');
    writeln();
    
    if N > 0 then
        writeln('Задача 20. N степень 3 = ', frac(ln(n) / ln(3)) = 0);
    
    s := 0;
    for i := 1 to n do
        if n mod i = 0 then
            s := s + i;
    writeln('Задача 24. Сумма всех натуральных делителей числа N (сключая 1 и N) = ', s);
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Даны целые числа x, y, z. если x ≤ y ≤ z, то вывести на экран квадраты этих чисел. если неравенство не выполняется, то вывести на экран наибольшее из чисел. , нужно написать программу на паскале с обязательным использованием условных вложенных операторов.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Nivanova995
jardi
metrikajulia
Ольга Сергей1822
Написать программу для кумира
shpakohat
Aleksandr768
Paradismebel
dmitryshigin
Pavlovna-Golovitinskaya378
nikomuneskazhu60
skorykin123371
Мартынова_Ринатовна1657
nevzorova
Ушакова1902
RozaAsadullina