Начало отсчета лет - 1984 год. Надо написать программу (pascalABC). Вводите год, нужный вам, отнимаете от него 1984 и находите остаток от деления на 12. Последовательность животных в 12-летнем цикле - крыса, корова, тигр, заяц, дракон, змея, лошадь, овца, обезьяна, курица, собака, свинья. То есть если при делении на 12 остаток равен 0, значит введенный год - год крысы, если 1 - год коровы и т.д.
Программа:
var a,b,c:longint;
begin
write('Введите год: ');
readln(a);
c:=a-1984;
b:=c mod 12;
case b of
0:writeln(a,' - год крысы');
1:writeln(a,' - год коровы');
2:writeln(a,' - год тигра');
3:writeln(a,' - год зайца');
4:writeln(a,' - год дракона');
5:writeln(a,' - год змеи');
6:writeln(a,' - год лошади');
7:writeln(a,' - год овцы');
8:writeln(a,' - год обезьяны');
9:writeln(a,' - год курицы');
10:writeln(a,' - год собаки');
11:writeln(a,' - год свиньи');
end;
end.
Поделитесь своими знаниями, ответьте на вопрос:
Заданы три числа a, b, c. определить, является ли заданное число k делителем хотя бы одного из этих чисел. написать программу на языке турбопаскаль. надо, плес выручите. буду .
const Q=10000;
var a:array [1..Q] of integer;
x,k,p,m,n,o:integer;
begin
write('a='); readln(m);
write('b='); readln(n);
a[1]:=m;
for x:=2 to (n-m+1) do
a[x]:=a[x-1]+1;
write('Положительные: ');
for x:=1 to (n-m+1) do
if a[x]>0 then begin inc(p); write(a[x],' '); end;
writeln;
write('Отрицательные: ');
for x:=1 to (n-m+1) do
if a[x]<0 then begin inc(o); write(a[x],' '); end;
writeln;
writeln('Положительных чисел:', p);
writeln('Отрицательных чисел:',o);
end.