Avdimov5
?>

8№ 971 в программе «: =» обозначает оператор присваивания, знаки «+», «–», «*» и «/» – соответственно операции сложения, вычитания, умножения и деления. правила выполнения операций и порядок действий соответствует правилам арифметики. определите значение переменной a после выполнения данного алгоритма: a : = 6 b : = 2 b : = a/2*b a : = 2*a+3*b в ответе укажите одно целое число — значение переменной a. 8 № 689 в программе «: =» обозначает оператор присваивания, знаки «+», «-», «*» и «/» — соответственно операции сложения, вычитания, умножения и деления. правила выполнения операций и порядок действий соответствуют правилам арифметики. определите значение переменной a после выполнения алгоритма: b : = 4 a : = -3 b : = 7 - 2*a - b a : = b/3 - a в ответе укажите одно целое число — значение переменной a. 8 № 846 в программе «: =» обозначает оператор присваивания, знаки «+», «–», «*» и «/» – соответственно операции сложения, вычитания, умножения и деления. правила выполнения операций и порядок действий соответствуют правилам арифметики. определите значение переменной a после выполнения алгоритма: a : = 4 b : = 6 a : = ( a / 2 ) * ( b / 2 ) a : = 2 * a + b в ответе укажите одно целое число — значение переменной a.

Информатика

Ответы

nmakarchuk

a = 30

a = 6

a = 14



Struev730
Если то вот так:
begin
  Writeln('Температура апреля:');
  var a:=ArrRandom(30,-10,10); a.Println;
  var sr:=a.Where(x->x>=0).Average;
  Writeln('Средняя температура для дней, когда >0 = ',sr:4:1);
  var k:=a.Where(x->x>=0).Count;
  if k=0 then writeln('No')
  else Writeln('Количество дней с температурой >0 = ',k);
  Writeln('Самая низкая температура: ',a.IndexMin+1,' день апреля');
end.

Пример:
Температура апреля:
-3 -5 9 7 0 -7 -3 8 -5 9 -5 1 -8 3 0 3 -2 -7 9 4 2 -4 -10 7 1 7 4 3 6 -2
Средняя температура для дней, когда >0 =  4.6
Количество дней с температурой >0 = 18
Самая низкая температура: 23 день апреля
YuREVICh646
// PascalABC.NET 3.2, сборка 1427 от 24.04.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=SeqRandom(ReadInteger('n='),-50,50).Select(n->double(n/10)).ToArray;
  a.ForEach(x->Write(x:0:1,' ')); Writeln;
  Writeln('Сумма отрицательных: ',a.Where(x->x<0).Sum);
  var p:=a.IndexMin;
  var q:=a.IndexMax;
  if p>q then Swap(p,q);
  Writeln('Произведение на интервале: ',
      a[p+1:q].Aggregate(1.0,(x,y)->x*y));
  Writeln('Сортировка:');
  a.Sort; a.ForEach(x->Write(x:0:1,' ')); Writeln;
end.

Пример
n= 13
1.7 -0.8 -1.3 -1.4 5.0 -3.1 -0.7 -2.7 2.6 -4.9 4.0 -2.0 -2.0
Сумма отрицательных: -18.9
Произведение на интервале: -15.2334
Сортировка:
-4.9 -3.1 -2.7 -2.0 -2.0 -1.4 -1.3 -0.8 -0.7 1.7 2.6 4.0 5.0

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

8№ 971 в программе «: =» обозначает оператор присваивания, знаки «+», «–», «*» и «/» – соответственно операции сложения, вычитания, умножения и деления. правила выполнения операций и порядок действий соответствует правилам арифметики. определите значение переменной a после выполнения данного алгоритма: a : = 6 b : = 2 b : = a/2*b a : = 2*a+3*b в ответе укажите одно целое число — значение переменной a. 8 № 689 в программе «: =» обозначает оператор присваивания, знаки «+», «-», «*» и «/» — соответственно операции сложения, вычитания, умножения и деления. правила выполнения операций и порядок действий соответствуют правилам арифметики. определите значение переменной a после выполнения алгоритма: b : = 4 a : = -3 b : = 7 - 2*a - b a : = b/3 - a в ответе укажите одно целое число — значение переменной a. 8 № 846 в программе «: =» обозначает оператор присваивания, знаки «+», «–», «*» и «/» – соответственно операции сложения, вычитания, умножения и деления. правила выполнения операций и порядок действий соответствуют правилам арифметики. определите значение переменной a после выполнения алгоритма: a : = 4 b : = 6 a : = ( a / 2 ) * ( b / 2 ) a : = 2 * a + b в ответе укажите одно целое число — значение переменной a.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

vikka30
muzaffarovich-Sergei1777
Olegovna Volkov
anikamalish
kryukovaem
ntyremsk1
potapin
Кочугурова
peshnoshamon
Vasilisan
smook0695
nastya3213868
Александрович686
aci2003
shuramuji