import java.util.Scanner;
public class Authenticator {
public static void main(String[] args) {
String login;
String password;
Scanner scan = new Scanner(System.in);
System.out.println("login:");
login = scan.next();
System.out.println("password:");
password = scan.next();
if(login.equals("user") && password.equals("qwerty")){
System.out.println("Authentication completed");
}else{
System.out.println("Invalid login or password");
}
scan.close();
}
}
Объяснение:
Краткий алгоритм этой программы:Импортируем класс Scanner(для ввода текста);В методе main создаем две переменные типа String и одну типа Scanner;Вводим значения при а;Если логин и пароль верны,то выводим Authentication completed. Иначе выводим Invalid login or password;Закрываем Scanner;Поделитесь своими знаниями, ответьте на вопрос:
Мир-2 напишите программу, которая считывает одну строку. и если из символов в строке можно составить слово "мир" в таком же порядке как в слове, выводит "найдено" или если такого слова нет "нет". для решения используй функцию .index() sample input: мир sample output: найдено питон ! ! !
1)Cначала заполняем массив случайными числами от 2 до 5 (включительно)
2)Потом выводим его (Для проверки)
3) Потом считаем оценки. Но сначала нужно обнулить переменные( В самом начале это делали), а то получится кака (:
program N_0547847;
var
b, c, d, f, i:integer;
a: array [1..20] of integer;
begin;
randomize;
b:=0; c:=0; d:=0; f:=0;
for i:=1 to 20 do begin
a[i]:=random(4)+2;
write(a[i],' '); end;
writeln;
for i:=1 to 20 do begin
if a[i]=2 then b:=b+1;
if a[i]=3 then c:=c+1;
if a[i]=4 then d:=d+1;
if a[i]=5 then f:=f+1;
end;
writeln('Двоек: ', b);
writeln('Троек: ', c);
writeln('Четверок: ',d);
writeln('Пятерок: ',f);
end.