Yevgenii1423
?>

Составьте программу, которая формирует массив из 8 случайных целых чисел от 1 до 20 и меняет местами значения 2-го и последнего элементов массива

Информатика

Ответы

amxvel7596
PascalABC.NET 3.4.2, сборка 1881 от 19.11.2018Внимание! Если программа не работает, обновите версию!

begin

 var a := ArrRandom(8, 1, 20);

 a.Println;

 Swap(a[1], a[a.High]);

 a.Println

end.

Пример14 19 18 5 2 8 1 1414 14 18 5 2 8 1 19
Тинчурина1528
Задача №1
//PascalABC.NET (версия 3.1, сборка 1196 от 09.03.2016)
Var n, i: integer; 
Begin                   
writeln ('Введите число');
readln(n);                                    
writeln('Делители числа:');  
for i := 1 to n div 2 do     
  if (n mod i) = 0 then begin 
    write(i,'  ');
  end;         
End.       

Задача №2 (алгоритм не очень шустрый, но работает и понятный)
//PascalABC.NET (версия 3.1, сборка 1196 от 09.03.2016)
var
  a, b, x, y, nod: integer;

begin
  writeln('Введите a,b');
  readln(a, b);
  x := a;y := b;
  while x <> y do
    if x > y
      then x := x - y
    else y := y - x;
  nod := x;
  writeln('NOD(', a, ',', b, ')=', nod);
end.
horst58
Var dv,tr,pt,dv1,tr1,pt1,dv2,tr2,pt2 :real;

procedure nod( var dv,tr,pt,dv1,tr1,pt1,dv2,tr2,pt2 :real; );
var a:array[1..6] of real;
i : integer;
begin
dv1:=100;
tr1:=100;
pt1:=100;
for i:= low(a) to high (a) do begin
readln(a[i]);
repeat
if( (a[i] mod 2) =0) then begin
a[i]:=a[i]/2;
dv:=dv+1;
end
else if( ( a[i] mod 3)=0) then begin
a[i]:=a[i]/3;
tr:=tr+1;
end
else if ( ( a[i] mod 5)=0) then begin
a[i]:=a[i]/5;
pt:=pt+1;
end;

untill(a=1);
if dvif trif ptdv:=0;
tr:=0;
pt:=0;
end;
if dv1>0 then dv2:=dv1*2 else dv2:=1;
if tr1>0 then tr2:=tr1*3 else tr2:=1;
if pt1>0 then pt2:=pt1*5 else pt2:=1;
nod:=dv2*tr2*pt2;
writeln(nod);
end;
begin
nod( dv,tr,pt,dv1,tr1,pt1,dv2,tr2,pt2 );
end.

end;

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу, которая формирует массив из 8 случайных целых чисел от 1 до 20 и меняет местами значения 2-го и последнего элементов массива
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

baxirchik
loa364
Varvara
yusinelnik8
Николаевна1564
ank9809
Любовь-Волков1205
rimmaskis
IrinaSolodukhina1495
lemoh
okison2847
asparinapti39
perminovaea
elmira070485
olechka197835