Татьяна_Полулях
?>

Напишите программу, которая предложит пользователю ввести длину строки n и ее члены-целые числа, и отобразит на экране следующую информацию: сам массив, среднее арифметическое всех четных чисел

Информатика

Ответы

tanyaandreeva728

javascript:var n = prompt("Введите n:"), массив = [], чётных = 0; for (let сч = 0; сч < n; сч++) массив.push(parseInt(prompt("["+сч+"]:"))); alert(массив + "\n" + (массив.reduce(function (пр, тек) { if (тек % 2 == 0) { чётных++; return пр + тек; } else return пр; }, 0) / чётных));

Shumnova42

var a:array of integer;

n,i,s,k:integer;

begin

write('Введите количество элементов массива: ');

readln(n);

a:=new integer[n];

for i:=0 to n-1 do read(a[i]);

write ('Массив: ');

for i:=0 to n-1 do write(a[i],'  ');

writeln;

for i:=0 to n-1 do

if a[i]mod 2 = 0 then

begin

s:=s+a[i];

k:=k+1

end;

writeln('Среднее арифметическое чётных элементов массива равно: ',s/k:0:3)

end.

lilit-yan

Объяснение:

1) В текущее активное окно (которое находится над всеми)

2) На панели состояния или панели инструментов в зависимости от системы

3) Откатится к последнему сохранению, так как отчистится ОЗУ

4) Да, это и есть текст (правда если это будет внешний код, то можно в этом сомневается, но в основном - да)

5) папка - папка, находящаяся в корне или в каталоге (какой - то диск), а вложенная папка - папка в папке

6) Сходство : обе сохраняют документ

Различие: сохранить как сохраняет как новый документ в новый путь с новым названием и возможно с новым расширением, а сохранить просто обновляет файл на диске

7) я не знаю, что вам задал учитель, скажите, сделаем!

Vasilisan

Системное ПО обеспечивает работу компьютера (загрузка ядра, драйверов, проверка портов, синхронизацию устройств и протоколов передачи данных, чтение, передачу данных, осуществляют слежение за устройствами ввода-вывода и реагируют на команды с них и т. д.) . Прикладные программы используют системное ПО, но выполняют действия и функции не влияющие на систему, а имеющие прикладное значение (просмотр и обработка видео, математические вычисления, запись на внешние носители, игры...).

Объяснение:

незнаю проавельный это ответ или нет

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая предложит пользователю ввести длину строки n и ее члены-целые числа, и отобразит на экране следующую информацию: сам массив, среднее арифметическое всех четных чисел
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Roman343247
migreen
barinovmisha2013
Татьяна1045
Дубровская571
myataplatinumb348
andreyduborezz2913
Bologova Golovach1989
Likhomanova63
Елена-Олег
re-art
zverevahelen
maksim1lssah575
Васильев1028
Алёна Геннадьевна98
▲