alanatan5757
?>

C++ code blocks напишите программу, которая в последовательнсти целых чисел определяет количество нечетных чисел, кратных 3. программа получает на выход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0-признак окончания ввода, не входит в последовательность количество чисел не превышает 1000. введеные числа по модулю не превышают 30 000. программа должна вывести два числа: длину последовательности (завершающий 0 не учитывается) и количество нечетных чисел, кратных 3.c

Информатика

Ответы

Yurevna
#include <iostream>
using namespace std;

int main() {
int k = 0;
int n = 0;
int x;
do {
cin >> x;
if (x != 0) {
++n;
if (x % 2 == 1 && x % 3 == 0) ++k;
}
} while (x != 0);
cout << n << " " << k << endl;
return 0;
}
movlam11
Const nx=30;var i,j,p,n:integer;A:array[1..nx,1..nx] of integer;d,Sn,min:real;begin p:=1;write('Введите размер матрицы');Read(n);for i:=1 to n do beginfor j:=1 to n do beginA[i,j]:=random(3)-2;write(A[i,j]:4);end;writeln;end;writeln;writeln;for i:=1 to n do beginfor j:=1 to n do beginif i = j then begin if A[i,j]<> 0 then p:=p* A[i,j];write(A[i,j]:4);endelse write(' ':4);end;writeln;end;write('p =',p);writeln;writeln;for i:=1 to n do beginfor j:=1 to n do beginif (i= n -j +1) then begin if A[i,j]<> 0 then p:=p* A[i,j];write(A[i,j]:4);endelse write(' ':4);end;writeln;end;write('p =',p);end.
Оксана Анна
//Pascal
  var a,b, I, maxsumm, max : integer;
 
  function summdel(x:integer):integer; //результат - сумма делителей х
  var k,sum:integer;
  begin
    sum:=0;
    for k := 1 to x div 2 + 1 do
      if x mod k = 0 then sum:= sum+k;
    summdel:=sum;
  end;
 
  begin
   writeln('Введите границы a,b ');
   readln(a,b);
    maxsumm := 1;
    max := 1;
    for i := a to b do
     begin
        if summdel(i) > maxsumm then
          begin maxsumm:= summdel(i);
            max := i;
          end;
     end;
     writeLn('Максимальная сумма делителей - ', maxsumm, ' число - ',max)
  end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

C++ code blocks напишите программу, которая в последовательнсти целых чисел определяет количество нечетных чисел, кратных 3. программа получает на выход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0-признак окончания ввода, не входит в последовательность количество чисел не превышает 1000. введеные числа по модулю не превышают 30 000. программа должна вывести два числа: длину последовательности (завершающий 0 не учитывается) и количество нечетных чисел, кратных 3.c
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Igorevich1512
Алексей Ксения
alexeytikhonov
tvmigunova551
Kuznetsova1639
Картузов-Алексей1252
SEMENOV25352
Vladimirovna1997
Бурмистрова-Ирина660
fafina12586
ivnivas2008
ooozita5
Evsevia-a
YuREVICh646
Sofinskaya1185