annashaykhattarova1
?>

Python ! ( максим едет на автобусе и, чтобы развеять скуку, придумал себе игру. он смотрит в окно и записывает все номера домов на тетрадный листок. на середине пути он берёт новый листок и продолжает записывать номера. в конце пути он хочет узнать, какие номера встретились ему в обоих списках, и выписывает их на третий листок. если таких номеров нет, то максим считает поездку не удачной и записывает слово empty. формат ввода сначала вводятся числа с первого листка: по одному на каждой строке. после этого идет пустая строка в качестве разделителя. затем вводятся числа со второго листочка, также по одному на каждой строке. завершение ввода — пустая строка. формат вывода номера, встретившиеся на обоих листках в любом порядке. если таких номеров нет, надо вывести слово empty.

Информатика

Ответы

yocrew13

Ага! Из ЯЛицея!

Ладно держи!

n = set()

n1 = set()

a = input()

while a != '':

   n.add(a)

   a = input()

a1 = input()

while a1 != '':

   n1.add(a1)

   a1 = input()

intersection = n & n1

if intersection == set():

   print('EEMPTY')

else:

   for e in intersection:

       print(e)

   print('\n')

по PEP8 ошибки исправь

и переменные переименуй

P. S. ' в Wing может не пойти. В этом случае замени их на ковычки

viktorovna_Imamaevich679
Код#include <iostream>constexpr double bites_to_megabytes(double a) {    return a / 8388608;}constexpr double megabytes_to_gigabytes(double a) {    return a / 1024;}int main() {    long long a;    short type;    bool is_correct = false;    double answer;    do {        std::cin >> a;        std::cout << "[1] Megabytes \n"                  << "[2] Gigabytes \n"                  << "Convert to [1] or [2]: ";        std::cin >> type;        if (type == 1 or type == 2) {            is_correct = true;        } else {            std::cout << "Meh. Try to type again. \n" << std:: endl;        }    } while (!is_correct);    switch (type) {        case 1:            answer = bites_to_megabytes(a);            break;        case 2:            answer = megabytes_to_gigabytes(bites_to_megabytes(a));            break;    }    std::cout << "An answer of conversion is " << answer << std::endl;    return 0;}
Людмила902
В задании не сказано, откуда берутся исходные данные, поэтому будем вводить их с клавиатуры. Сначала ведем общее количество данных (не факт, что данные за месяц снимались строго ежедневно), а затем сами данные. Это позволит заодно осуществить контроль ввода.

var
  n,s,t,i:integer;
begin
  Write('Укажите количество данных: ');
  Read(n);
  Writeln('Теперь вводите данные');
  s:=0;
  for i:=1 to n do
    begin
    Read(t);
    s:=s+t
    end;
  Writeln('Средняя температура за месяц составила ',s/n:0:1)
end.

Пример решения

Укажите количество данных: 11
Теперь вводите данные
27 29 26 31 24 23 27 30 31 28 25
Средняя температура за месяц составила 27.4

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Python ! ( максим едет на автобусе и, чтобы развеять скуку, придумал себе игру. он смотрит в окно и записывает все номера домов на тетрадный листок. на середине пути он берёт новый листок и продолжает записывать номера. в конце пути он хочет узнать, какие номера встретились ему в обоих списках, и выписывает их на третий листок. если таких номеров нет, то максим считает поездку не удачной и записывает слово empty. формат ввода сначала вводятся числа с первого листка: по одному на каждой строке. после этого идет пустая строка в качестве разделителя. затем вводятся числа со второго листочка, также по одному на каждой строке. завершение ввода — пустая строка. формат вывода номера, встретившиеся на обоих листках в любом порядке. если таких номеров нет, надо вывести слово empty.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ovalenceva77
alexey
isinyakin
Mexx9050
Ignateva737
mariapronina720126
hrim5736
dearmaria
Ермакова Ирина674
Эрендженова
moskvabelarus
kirillprotopopov1
yurazharov
mausgaly
alyans29