Ka-shop2791
?>

Напишите программу, которая запрашивает расход бензина в европейском стиле (количество литров на 100 км) и преобразует его в стиль, принятый в сша — число миль на галлон. обратите внимание, что кроме использования других единиц измерений, принятый в сша подход (расстояние/топливо) противоположен европейскому (топливо/расстояние учтите, что 100 километров соответствуют 62.14 милям, а 1 галлон составляет 3.875 литра. таким образом, 19 миль на галлон примерно равно 12.4 литров на 100 км, а 27 миль на галлон — примерно 8.7 литров на 100 км.

Информатика

Ответы

daskal83

c++выделить код

1

m2 = m1 * l1 / g1 * 10; // расчёт количества миль на галлон.

Ter-Pogosov_Vasilevna
Var
    a: array[0..10] of integer;
    i, n, k: integer;
//    b: array[1..4, 1..4] of integer;

begin
    Println();
    Println(1);
    for i := 0 to 10 do
        A[i] := i + 1;
    PrintLn(a);
    Println();
    for i := 1 to 10 do
    begin
        A[i] := A[i - 1];
        PrintLn(a);
    end;
    
    Println();
    Println(2);
    for i := 0 to 10 do
        A[i] := i + 1;
    PrintLn(a);
    Println();
    for i := 10 downto 0 do
    begin
        A[i] := A[10 - i];
        PrintLn(a);
    end;
end.

Тут вывод трасировок последних циклов

1
[1,2,3,4,5,6,7,8,9,10,11]

[1,1,3,4,5,6,7,8,9,10,11]
[1,1,1,4,5,6,7,8,9,10,11]
[1,1,1,1,5,6,7,8,9,10,11]
[1,1,1,1,1,6,7,8,9,10,11]
[1,1,1,1,1,1,7,8,9,10,11]
[1,1,1,1,1,1,1,8,9,10,11]
[1,1,1,1,1,1,1,1,9,10,11]
[1,1,1,1,1,1,1,1,1,10,11]
[1,1,1,1,1,1,1,1,1,1,11]
[1,1,1,1,1,1,1,1,1,1,1]

2
[1,2,3,4,5,6,7,8,9,10,11]

[1,2,3,4,5,6,7,8,9,10,1]
[1,2,3,4,5,6,7,8,9,2,1]
[1,2,3,4,5,6,7,8,3,2,1]
[1,2,3,4,5,6,7,4,3,2,1]
[1,2,3,4,5,6,5,4,3,2,1]
[1,2,3,4,5,6,5,4,3,2,1]
[1,2,3,4,5,6,5,4,3,2,1]
[1,2,3,4,5,6,5,4,3,2,1]
[1,2,3,4,5,6,5,4,3,2,1]
[1,2,3,4,5,6,5,4,3,2,1]
[1,2,3,4,5,6,5,4,3,2,1]
sbraginets
Все элементы будут равны единице.
Сначала они будут заполнены значением, большим своего индекса на 1, а потом каждому элементу, начиная со второго (который А[1]) будет присвоено значение предыдущего элемента и 1 распространится везде.

Для проверки была написана программа с отладочной выдачей.

var
  a:array[0..10] of integer;
  i:integer;
begin
  for i:=0 to 10 do begin a[i]:=i+1; Write(a[i],' ') end;
  Writeln;
  Write(a[0],' ');
  for i:=1 to 10 do begin a[i]:=a[i-1]; Write(a[i],' ') end
end.

Результаты

1 2 3 4 5 6 7 8 9 10 11
1 1 1 1 1 1 1 1 1 1 1

ответ: 3)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая запрашивает расход бензина в европейском стиле (количество литров на 100 км) и преобразует его в стиль, принятый в сша — число миль на галлон. обратите внимание, что кроме использования других единиц измерений, принятый в сша подход (расстояние/топливо) противоположен европейскому (топливо/расстояние учтите, что 100 километров соответствуют 62.14 милям, а 1 галлон составляет 3.875 литра. таким образом, 19 миль на галлон примерно равно 12.4 литров на 100 км, а 27 миль на галлон — примерно 8.7 литров на 100 км.
Ваше имя (никнейм)*
Email*
Комментарий*