Sergei_sergei
?>

Написать программу в с++.условие: "выводить на экран удвоенное значение четных чисел, значения нечётных чисел выводить без изменений".

Информатика

Ответы

pk199888
#include <iostream>
using namespace std;
int main (){
int a;
cin>>a;
if (a%2==0){
int b = a*2;
cout <<b;
}
else {
cout <<a;
}
return 0;
}
zolotayaoxana1982
1) Частота дискретизации 44.1 кГц означает, что в секунду делается 44 100 отсчетов. Разрешение 16 бит (т.е. 16/8=2 байта) требует для хранения каждого отсчета 2 байта, а для хранения информации за 1 секунду - 2 х 44 100 = 88 200 байт. Две минуты - это 2 х 60 = 120 секунд и тогда общий объём составит
88 200 х 120 = 10 584 000 байт или 10 584 000 / 1024 = 10 335.94 Кбайт, или 10 335.94 / 1024 = 10.1 Мбайт
И все это - для одного канала записи (монофонической). Если запись стереофоническая - то каналов два и потребуется 2 х 10.1 = 20.2 Мбайта и т.д.
2) В этой задаче много неизвестных, а ход её решения обратный по отношению к предыдущей задаче. 2.6 Мбайта = 2.6 х 1024² = 2 726 297.6 байт. В одной минуте 60с, поэтому объем информации за одну секунду не может превышать 2 726 297.6 / 60 = 45 438.3 байт. А теперь это число нужно разделить на произведение трех значений: количества каналов записи, частоты дискретизации в герцах и разрешения (количества байт, отводимых для хранения одного отсчета). Все эти значения нам неизвестны, поэтому у задачи нет однозначного решения. Например, если канал один, а разрешение равно 1 байту, то частота дискретизации не может превышать 45 438 байт, что примерно соответствует общепринятой частоте 44 100 Гц (44.1 кГц).
Mariya-Karaseva
1) Частота дискретизации 44.1 кГц означает, что в секунду делается 44 100 отсчетов. Разрешение 16 бит (т.е. 16/8=2 байта) требует для хранения каждого отсчета 2 байта, а для хранения информации за 1 секунду - 2 х 44 100 = 88 200 байт. Две минуты - это 2 х 60 = 120 секунд и тогда общий объём составит
88 200 х 120 = 10 584 000 байт или 10 584 000 / 1024 = 10 335.94 Кбайт, или 10 335.94 / 1024 = 10.1 Мбайт
И все это - для одного канала записи (монофонической). Если запись стереофоническая - то каналов два и потребуется 2 х 10.1 = 20.2 Мбайта и т.д.
2) В этой задаче много неизвестных, а ход её решения обратный по отношению к предыдущей задаче. 2.6 Мбайта = 2.6 х 1024² = 2 726 297.6 байт. В одной минуте 60с, поэтому объем информации за одну секунду не может превышать 2 726 297.6 / 60 = 45 438.3 байт. А теперь это число нужно разделить на произведение трех значений: количества каналов записи, частоты дискретизации в герцах и разрешения (количества байт, отводимых для хранения одного отсчета). Все эти значения нам неизвестны, поэтому у задачи нет однозначного решения. Например, если канал один, а разрешение равно 1 байту, то частота дискретизации не может превышать 45 438 байт, что примерно соответствует общепринятой частоте 44 100 Гц (44.1 кГц).

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу в с++.условие: "выводить на экран удвоенное значение четных чисел, значения нечётных чисел выводить без изменений".
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

koxhulya61
Koshovkina1721
best00
oalexandrova75
eidevyatkina
Ruzalina_Svetlana1435
Stanislavovna1237
yliana
JisesLove19955
Bella
dmitryshigin
Бочкарева Горохова1652
baeva-larisa8165
milkiev
shumilovs7252