Zakharov Lilit
?>

Составить программу , которая формирует массив из 50 случайных целых чисел на промежутке [-40; 40].вывести на экран сформированный массив, а также сумму элементов, которые являются числами кратными

Информатика

Ответы

pastore

var массив = []; for (let сч = 0; сч < 50; сч++) массив.push((function (от, до) { return Math.floor(от + Math.random() * (до + 1 - от)); })(-40, 40)); alert(массив); alert(массив.reduce (пр, зн) { return пр + (зн % 4 == 0 ? зн : 0); }, 0);

departed744

Когда вы открываете документ PowerPoint, отображается лента, которая выглядит как ряд ярлыков, также называемых вкладками.

Если щелкнуть одну из вкладок ленты, она откроется и вы увидите инструменты и функции, которые в более ранних версиях PowerPoint находились в меню и на панелях инструментов.

Если вы видите функцию со стрелкой Значок стрелки вниз для создания закладки, вы можете щелкнуть ее, чтобы получить дополнительные сведения или параметры.

Вы также можете заметить Значок кнопки в углу некоторых групп ленты, таких как буфер обмена и группы шрифтов. Щелкните их, чтобы открыть диалоговое окно, связанное с этой функцией. Например, в окне запуска в группе "Шрифт" открывается поле "Шрифт", в котором можно настроить такие эффекты, как заметок, надстрочными знаками или интервалы между знаками.

Amelin-Alipova

try:

 n = int(input("Please, input an N: "))

except:

 print("N - should be an integer")

if ( n > 64):

   print("N should be lower than 64")

   print("The program is closed")

   exit(0)

print("Filling array B from file...")

b = []

my_file = open("c:\B_array.txt", "r")

content = my_file.read()

b = content.split(",")

my_file.close()

print("Filling associate array A NxN from array B...")

a_row = []

a = []

for j in range(n):

 a_row = []

 for i in range(n):

   a_row.append(b[j*n+i])

 a.append(a_row)

print("Array A: "+ str(a))

print("Array B: " + str(b))

Объяснение:

Все описание в самой программе

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу , которая формирует массив из 50 случайных целых чисел на промежутке [-40; 40].вывести на экран сформированный массив, а также сумму элементов, которые являются числами кратными
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

svetarakityanskaya
Lolira64
ann-perminova2008
Natalya1895
Mbkozlov6
aci2003
teya07
puchkovajulia
mbykovskiy
marinakmaa86
yurievaalxndra55
Bogataya Vladimir318
Anatolevich667
Shevtsov1818
betepah