Yuliya701
?>

Напишите программу, которая создаёт и выводит массив из действительных чисел случайным размером от 4 до 10 строк и столбцов, затем через пустую строку выводит тот же массив, но выводит его столбец так, чтобы поменялся местами с последним.

Информатика

Ответы

rstas
PascalABC.NET 3.4.2, сборка 1884 от 24.11.2018Внимание! Если программа не работает, обновите версию!

begin

 var (m, n) := (Random(4, 10), Random(4, 10));

 Writeln('*** Исходный массив ***');

 var a := MatrRandomReal(m, n, -99, 99);

 a.Println(8, 3);

 Writeln('*** Полученный массив ***');

 a.SwapCols(1, a.ColCount - 1);

 a.Println(8, 3)

end.


Напишите программу, которая создаёт и выводит массив из действительных чисел случайным размером от 4
Mikhailovna1444

1:Те́кстовый реда́ктор — самостоятельная компьютерная программа или компонент программного комплекса, предназначенная для создания и изменения текстовых данных в общем и текстовых файлов, в частности. Текстовые редакторы предназначены для работы с текстовыми файлами в интерактивном режи

2 Текстовый редактор — это программа, используемая специально для ввода и редактирования текстовых данных.

3 Word (дальше хз)

4 Документ – это материальный носитель, содержащий какую-либо информацию. Обычно подразумевается, что она выражена в текстовом виде, хотя существуют фотодокументы, видео- и аудио-. От обычного текста он отличается наличием реквизитов.

5 принтер

6 я не поняла этот вопрос. объясни его в комментариях и я отвечу

modno-trikotazh

предметное содержание информации позволяет уяснить ее основные свойства:

объективность информации  -  информация – это отображение окружающего мира, а он существует независимо от нашего сознания, знаний и мыслей о нем.

примеры:

1)          фома неверующий

2)            игра «глухой телефон»

 

информация достоверна, если она отражает истинное положение дел. недостоверная информация может к неправильному пониманию или принятию неправильных решений.

примеры:

1)          пропущено занятие, подруга говорит, что ничего не задано.

2)          скачали информацию в интернете

 

информация полна, если ее достаточно для понимания и принятия решений. неполнота информации сдерживает    принятие    решений    или    может    повлечь    ошибки.

примеры:

1)          пропущено занятие, подруга говорит, что  задан только параграф и забывает про .

2)          на улице 200с    (не понятно + или -)

 

                актуальность (своевременность)  –  важность, необходимость для данного времени.  актуальную информацию  важно  иметь    при    работе    в    изменившихся    условиях.

                примеры:

1)            накануне о контрольной работе

2)            прогноз погоды на завтра актуальнее прогноза на вчера

 

полезность (ценность)  зависит от потребностей конкретных людей и от тех , которые можно решать с полученной информации.

примеры:

1) в расписании уроков указаны занятия для всех классов, для вас ценна информация лишь о ваших уроках

2) просмотрен документальный фильм про петра 1. на уроке информатике он ценности не имеет, но на уроке - имеет.

 

понятность.  если ценная и актуальная информация выражена непонятными словами, она может стать бесполезной. информация становится  понятной, если она выражена языком, на котором говорят те, кому предназначена эта информация.

примеры:

1)          дошкольник спрашивает у старшеклассника: "как светит лампочка? ". в ответ слышит: "существует две теории света – волновая и корпускулярная. согласно первой …".

2)          объяснять материал на китайском языке.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая создаёт и выводит массив из действительных чисел случайным размером от 4 до 10 строк и столбцов, затем через пустую строку выводит тот же массив, но выводит его столбец так, чтобы поменялся местами с последним.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Пономаренко
Aleksandrovna Kolesnik1764
sawa-msk
irina-mic
picsell
zubov-073620
waspmoto6188
Калмыкова-Петрунина
Лоскутова
victors
Larisa-Andrei
Анастасия Елена
Viktoromto
galinab1111326
shumilovs7252