KonovalovKonstantinovna1306
?>

Составить программу на языке c++ которая будет определять количество точек с целочисленными координатами принадлежащих кругу с радиусом r , с центром в начале координат.

Информатика

Ответы

Espivak

#include <iostream>


using namespace std;



int main() {


  long long i,j,r,n;


  cout<<"r = ";  cin>>r;


  i=r; j=1; n=0;


  while (i>=1) {


      while (i*i+j*j<=r*r) j=j+1;


      n=n+r-j+1;


      i--;


  }


  n=2*(2*r+1)-1+4*r*r-n*4;


  cout<<n<<endl;


  system("pause");


  return(0);


}



Составить программу на языке c++ которая будет определять количество точек с целочисленными координа
restkof
Честно, не поняла ваш код вообще. Почему нет цикла? Предлагаю свое решение:
1)Cначала заполняем массив случайными числами от 2 до 5 (включительно)
2)Потом выводим его (Для проверки)
3) Потом считаем оценки. Но сначала нужно обнулить переменные( В самом начале это делали), а то получится кака (:

program N_0547847;
var
    b, c, d, f, i:integer;
    a: array [1..20] of integer;
begin;
randomize;
b:=0; c:=0; d:=0; f:=0;
for i:=1 to 20 do begin
  a[i]:=random(4)+2; 
  write(a[i],' '); end; 
writeln;
for i:=1 to 20 do begin
    if a[i]=2 then  b:=b+1;
    if a[i]=3 then  c:=c+1;
    if a[i]=4 then  d:=d+1;
    if a[i]=5 then   f:=f+1;
end;
writeln('Двоек: ', b); 
writeln('Троек: ', c); 
writeln('Четверок: ',d);
writeln('Пятерок: ',f);
end.   
Теплова

import java.util.Scanner;

public class Authenticator {

public static void main(String[] args) {

 String login;

 String password;

 Scanner scan = new Scanner(System.in);

 

 System.out.println("login:");

 login = scan.next();

 System.out.println("password:");

 password = scan.next();

 

 if(login.equals("user") && password.equals("qwerty")){

  System.out.println("Authentication completed");

 }else{

  System.out.println("Invalid login or password");

 }

 

 scan.close();

 

}

}

Объяснение:

Краткий алгоритм этой программы:Импортируем класс Scanner(для ввода текста);В методе main создаем две переменные типа String и одну типа Scanner;Вводим значения при а;Если логин и пароль верны,то выводим Authentication completed. Иначе выводим Invalid login or password;Закрываем Scanner;

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу на языке c++ которая будет определять количество точек с целочисленными координатами принадлежащих кругу с радиусом r , с центром в начале координат.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

byfetvostochniy
MikhailSvetlana
tarrin-ka
Vladislav98
kondrashovalf6404
mail2017
armusaeff
agutty3
Lazar
marinamarinazmeeva2444
oleonov
Novikova
arnika-ooo1
jenn055
oldulo74