inessa12006
?>

Определите среднее арифметическое чётных элементов массива a[1..10] написать программу в паскаль

Информатика

Ответы

vsbrelok

//Будем считать, что четные по значению

const

 n = 10;

var

 a: array[1..n] of integer;

 i, Sum, Count: integer;

begin

 Sum := 0;

 Count := 0;

 Randomize;

 for i := 1 to n do

 begin

   a[i] := Random(10);

   Write(a[i], ' ');

   if a[i] mod 2 = 0 then

   begin

     Sum := Sum + a[i];

     Count := Count + 1

   end

 end;

 

 Writeln;

 Write('Среднее арифметическое ' +  

       'четных чисел: ', Sum / Count)

end.

Viktorovna1012

Здесь с четными, а там просто арефмитическое...


Var

m:array [1..100000] of integer;

k,i:integer;

Begin

k:=0;

randomize;

For i:=1 to 10 do

read(m[i]);

For i:=1 to 10 do begin

If m[i] mod 2=0 then

k:=k+m[i] else k:=k+0;end;

k:=k div 10;

writeln(k);

end.

alf206

#include <stdlib.h>

#include <time.h>

#include <iostream>

using namespace std;

#define N 16

void main()

{

   int randomNumbers[N];

   srand(time(NULL));

   for (int i = 0;i < N; i++)

   {

       randomNumbers[i] = rand() % 40 - 20;

       cout << "randomNumber[" << i << "] = " << randomNumbers[i] << endl;

   }

   cout << endl;

   int counter = 0;

   for (int i = 0; i < N; i++)

   {

       if (randomNumbers[i] < 0)

       {

           counter++;

       }

   }

   cout << "counter = " << counter << endl;

}

papushinrv4985

#include <stdlib.h>

#include <time.h>

#include <iostream>

using namespace std;

#define N 16

void main()

{

   int randomNumbers[N];

   srand(time(NULL));

   for (int i = 0;i < N; i++)

   {

       randomNumbers[i] = rand() % 40 - 20;

       cout << "randomNumber[" << i << "] = " << randomNumbers[i] << endl;

   }

   cout << endl;

   int counter = 0;

   for (int i = 0; i < N; i++)

   {

       if (randomNumbers[i] < 0)

       {

           counter++;

       }

   }

   cout << "counter = " << counter << endl;

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Определите среднее арифметическое чётных элементов массива a[1..10] написать программу в паскаль
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

vladburakoff5
alenchik19938823
snopovajulia
antrotip
ИП-Сысоев1628
myhauz
tenvalerij
Голосова-Лобанов1555
kristina1989
zrv85
zibuxin6
andreanikin
ПодлеснаяМакарова1883
СмыковаДарья1969
ksoboleva