Кирьяков-Крикунов
?>

Написать программу которая будет выводить положительные числа до тех пор пока не будет введена цыфра -1 python

Информатика

Ответы

Olegovich Nikolaevna

a = 1

n = 4 #odd

b = 3 #even

while a != -1:

 a = int(input("Insert number:"))

 if a == -1:

   break

 if > b

   b += 1  

 if a > n

   n += 1

   print(odd)  

elena-ruzadom
C case
Var
    a:integer;
Begin  
   Write('Введите число от 5 до 9: '); readln(a);  
     case a of  
     5:writeln('Вы ввели число "пять"');
     6:writeln('Вы ввели число "шесть"');
     7:writeln('Вы ввели число "семь"');
     8:writeln('Вы ввели число "восемь"');
     9:writeln('Вы ввели число "девять"')
   end;

readln
End.

С if
Var
    a:integer;
Begin
  Write('Введите число от 5 до 9: '); readln(a);
if a=5 then writeln('Вы ввели число "пять"');
if a=6 then writeln('Вы ввели число "шесть"');
if a=7 then writeln('Вы ввели число "семь"');
if a=8 then writeln('Вы ввели число "восемь"');
if a=9 then writeln('Вы ввели число "девять"');

readln
End.
rigina82
1. Вероятность вынуть первым красный карандаш определяется отношением количества красных карандашей к их общему числу, т.е. 2/4 или 1/2.
2. Теперь в коробке остался один красный карандаш, а всего карандашей - три. Вероятность вынуть красный карандаш равна 1/3.
3. Вероятность наступления обоих событий определяется произведением обоих вероятностей и составляет 1/2 × 1/3 = 1/6
Итак, два красных (а также два синих) карандаша можно вынуть с вероятностью 1/6.
Сумма всех вероятностей равна 1, с вероятностью 1/6 оба карандаша будут красные, 1/6 - синие, значит на долю события, когда карандаши будут разного цвета остается 1 - 1/6 - 1/6 = 2/3

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу которая будет выводить положительные числа до тех пор пока не будет введена цыфра -1 python
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Рамиль211
vladimirkirv
de1979nis
goryavinan
olesya-kwas
Ragim777hazarovich
смирнов1127
shalashcoffee
VladimirovnaSimonov
amarantmetall
troian07
gamolml
adminaa
Lianchikavon
kol-nat26
▲