egoryandiana3727283
?>

Дан массив из 10 чисел. определите, сколько элементов этого массива имеют минимальное значение. (паскаль)

Информатика

Ответы

ivanovanata36937365

Если одномерный массив, то:

program min;

var a:array[1..10] of integer;

i,min,k:integer;

begin

writeln('Введите элементы массива');

for i:=1 to 10 do

readln(a[i]);

min:=a{1];

for i:=1 to 10 do

if a{i]<min

then min:=a{i};

for i:=1 to 10 do

if a{i]=min

then k:=k+1;

writeln('Всего элементов с минимальным значением =',k);

end.

Ruslanovich1217

Задача №2

800*600*16 (16 бит на пиксель это 65 536 цветов)=7680000 - бит информационный вес одного поля кадра.

Допустим частота обновления экрана монитора 60 Гц, тогда

7680000*60 (Гц)=460800000 бит в секунду * 60 (секунд)= 27648000000 бит - информационная емкость потока фильма в течении 1 минуты.

Постичаем в байтах

27648000000/8/1024/1024/1024=3.2186 Гигабайт - объём информационного потока

Задача №3

за одну секунду пройдет 36 мегабайт

2 часа = 7200 секунд *36=259200 мегабайт=253.12 Гбайт

 

Р.S. Это только в файле ваши фильмы нетакие большие, а при проигрывании при декомпрессии по шине памяти и по вашим HDMI проводам именно такие потоки и идут

 

kosharikclub
Дано: 
Продолжительность фильма t=60 сек.,  разрешение монитора 800х600 пикселей, n - кол-во цветов 65536, s- частота 16 кадр/сек.
Найти V - Объем файла.

Решение: 
1. Определим глубину цвета i  по формуле: n=2^i = 65536 =2^i  i= 16 бит на пиксель
2. Размер одного кадра R = Разрешение монитора* i= 800*600*16 = 7680000 бит.
3. Тогда объем памяти одноминутного фильма равен V=R*s*t = 7680000*16*60=  7372800000 бит 
7372800000/8 = 921600000 байт
921600000/1024= 900000 Кбайт
900000/1024= 878,9 Мбайт

ответ: Объем памяти равен 878,9 МБ 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дан массив из 10 чисел. определите, сколько элементов этого массива имеют минимальное значение. (паскаль)
Ваше имя (никнейм)*
Email*
Комментарий*
▲