linda3930
?>

Написать программу, которая в зависимости от значения переменной а на экран выводится наименование оценки. предусмотреть вывод сообщения об ошибке в случае, когда введено число вне интервала 2..5python)

Информатика

Ответы

MaratФам

a = int(input("Введите число: "))

if a == 5:

       print("Пять")

elif a == 4:

       print("Четыре")

elif a == 3:

       print("Три")

elif a == 2:

       print("Два")

else:

       print("Error")

re-art

import java.util.Scanner;

class Main {

   static int getNumb() {

       Scanner sxy = new Scanner(System.in);

       return sxy.nextInt();

   }

   public static void main(String [ ] args) {

       int x1 = getNumb();

       int y1 = getNumb();

       int x2 = getNumb();

       int y2 = getNumb();

       String can = "NO";

       if((x1 + 1 == x2) || (x1 - 1 == x2) && y1 == y2) {

           can = "YES";

       }

       else if((y1 + 1 == y2) || (y1 - 1 == y2) && x1 == x2) {

           can = "YES";

       }

       else if((x1 + 1 == x2 && y1 + 1 == y2) || (x1 + 1 == x2 && y1 - 1 == y2) || (x1 - 1 == x2 && y1 + 1 == y2) || (x1 - 1 == x2 && y1 - 1 == y2)) {

           can = "YES";

       }

       System.out.print(can);

   }

}

Максим_Нина

Это таблица истинности для логических функций. Галочка вверх означает логическое И, галочка вниз - логическое ИЛИ, уголок перед переменной - логическое НЕ. Это тема обширная, и так что если я представлю здесь решение это все равно вам не понять. Вам нужно почитать о логических функциях и таблицах истинности.

Вот как выглядит решение. Поставляем значения из таблицы истинности в варианты функций. Та функция, результат которой совпадает с результатом из таблицы, является ответом. В данном случае это номер 2

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая в зависимости от значения переменной а на экран выводится наименование оценки. предусмотреть вывод сообщения об ошибке в случае, когда введено число вне интервала 2..5python)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Veselova
motor2218
kv135549
Anastasiamoscow80
Deniskotvitsky6422
Alekseevna1064
Yurevich1291
pozhidaevgv
Сумарокова
aetolstih
tsigankova2018
Пономаренко
matoksana
vapebroshop
tanysha1990