gallush9
?>

Составить программу которая в зависимости от порядкового номера месяца выдает сообщение о времени года

Информатика

Ответы

POMILEVAVladimirovna269
Uses crt; var a: 0..12; b: string; begin writeln('номер месяца'); readln(a); case a of 1: begin b: ='январь'; end; 2: begin b: ='февраль'; end; 3: begin b: ='март'; end; 4: begin b: ='апрель'; end; 5: begin b: ='май'; end; 6: begin b: ='июнь'; end; 7: begin b: ='июль'; end; 8: begin b: ='август'; end; 9: begin b: ='сентябрь'; end; 10: begin b: ='октябрь'; end; 11: begin b: ='ноябрь'; end; 12: begin b: ='декабрь'; end; end; writeln(b); readln; end.
sanyaborisov910067

1.

string = input().split(" ")

for i in string:

   if i[-1]=="я":

       print(i)

2.

massiv=list(map(int,input().split(" ")))

maxim=max(massiv)

for i in massiv:

   if i%2==1 and i<maxim:

       maxim=i

if max(massiv)%2==0 and maxim==max(massiv):

   print("Нету нечетных элементов")

else:

   print(maxim)

3.  

massiva=[input() for i in range(10)]

massivb=[input() for i in range(10)]

massiva,massivb=massivb,massiva

print(massiva,massivb)

4.

massiva=list(map(int,input().split(" ")))

massivb=list(map(int,input().split(" ")))

massivc=list(map(int,input().split(" ")))

print("Сумма 1 массива:",sum(massiva), "Среднее арифметическое:", sum(massiva)/len(massiva))

print("Сумма 2 массива:",sum(massivb), "Среднее арифметическое:", sum(massivb)/len(massivb))

print("Сумма 3 массива:",sum(massivc), "Среднее арифметическое:", sum(massivc)/len(massivc))

alyans29

import array

a = array.array ('i',[])

import random

_summ = _elem = 0

_len = int (input ("Lenght: "))

for l in range(_len):

   a.append(random.randrange(0,700))

   if a[l] < 50:

       _summ+=a[l]

       _elem+=1

print ("Summ: ", _summ)

if _elem != 0:

   print("Average: ", _summ/_elem)

else:

   print("Average: 0!")

print("Mass: ", a)

Результат работы:

Lenght: 20

Summ:  7

Average:  7.0

Mass:  array('i', [266, 89, 7, 407, 506, 130, 630, 362, 419, 82, 639, 619, 695, 383, 685, 477, 368, 81, 62, 199])

Lenght: 5

Summ:  18

Average:  18.0

Mass:  array('i', [486, 170, 18, 183, 307])

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу которая в зависимости от порядкового номера месяца выдает сообщение о времени года
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Sergei1198
al2nik2ol
Радецкая264
suturinavaleriya51
Kashtanov Anna
a580028r
Mark-Petrovich
sarycheva659
А Дзукаев1562
Pavlovna897
manimen345
rpforma71189
Исакова-Александрович511
Abdullaev
sarbaevmax