Linichuk
?>

Дан массив, состоящий из 14 элементов. массив заполняется пользователем после запуска программы. составьте программу нахождения количества элементов > 15 в массиве

Информатика

Ответы

Смирнов_Андрей691

const n=14;

var a:array [1..n] of integer;

i,k:integer ;

begin

for i:=1 to n do read(a[i]);

write ('Массив: ');

for i:=1 to n do

begin

if a[i]>15 then k:=k+1;

write (a[i],' ')

end;

writeln;

writeln('Количество элементов больше 15: ',k);

end.

Геннадьевна Вета560

from random import randint

mass = [randint(-20, 10) for i in range(5)]

a = []

b = []

for i in range(5):

   if mass[i] >= 0:

       a.append(mass[i])

   else:

       b.append(mass[i])

print(f'Массив: {" ".join(str(s) for s in mass)}')

if len(a) != 0 and len(b) != 0:

   print(f'Ср. ариф. элементов [{min(b)},{max(b)}]: {sum(b) / len(b)}')

   print(f'Ср. ариф. элементов [{min(a)},{max(a)}]: {sum(a) / len(a)}')

if len(a) == 0:

   print(f'Ср. ариф. элементов [{min(b)},{max(b)}]: {sum(b) / len(b)}')

   print(f'Ср. ариф. элементов 0: 0')

if len(b) == 0:

   print(f'Ср. ариф. элементов 0: 0')

   print(f'Ср. ариф. элементов [{min(a)},{max(a)}]: {sum(a) / len(a)}')

Объяснение:

СмыковаДарья1969

Language Integrated Query (LINQ - Language Integrated Query) - проект Microsoft по додаванню синтаксису мови запитів, що нагадує SQL, в мови програмування платформи .NET Framework. LINQ випущена разом з Visual Studio 2008 у кінці листопада 2007 року.

LINQ є набором функцій, що розширюють можливості запиту в синтаксисі мови C# і Visual Basic. LINQ надає стандартні шаблони для створення запитів і оновлення даних; технологія може бути розширена для підтримки потенційно будь-якого типу джерел даних (масиви, колекції, бази даних, документи XML, сутності (Entity)).  

Архітектура LINQ показана на рис. 18.1.

Принцип LINQ полягає в тому, що усі елементи мови повинні виконувати одну і ту саму роботу незалежно від джерела даних. Проте, не дивлячись на те, що синтаксис працює з усіма типами джерел даних, постачальник запиту, що зв'язує дані з самим джерелом даних, може реалізувати цю поведінку по різному.


Что такое LINQ в C# ? я не знаю. Я на ассемблере пишу и не врубаюсь.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дан массив, состоящий из 14 элементов. массив заполняется пользователем после запуска программы. составьте программу нахождения количества элементов > 15 в массиве
Ваше имя (никнейм)*
Email*
Комментарий*