Yekaterina_Popova1413
?>

Составить программу которая считывает 6 чисел и найти сумму неотрицательных чисел.

Информатика

Ответы

marketing601

var i,a,sum:longint;


begin

sum:=0;


for i:=1 to 6 do begin readln(a); if(a>0) then sum:=sum+a; end;


writeln(sum);


end.

shuxratmaxmedov

Шаг 1.

В алфавите, согласно условию задачи, ровно 15 символов.

Шаг 2.

Давайте посмотрим, сколько нужно минимум выделить бит на 1 символ из алфавита, состоящего из 15 символов.

Если бы мы выделили 1 бит информации, то он бы смог закодировать 1 символ алфавита, состоящего не более чем из 2 символов. А у нас их 15 Значит, 1 бита мало.

Если выделить 2 бита, то закодировать можно символ в алфавите максимум из 4 символов. Мало.

Если выделить 3 бита, то закодировать можно символ в алфавите максимум из 8 символов. Мало.

Если выделить 4 бита, то закодировать можно символ в алфавите максимум из 16 символов. Достаточно.

Значит, для кодирования 1 символа данного алфавита достаточно 4 бит.

Шаг 3.

1 пароль состоит из 15-ти символов.

1 символ "весит" 4 бита.

Значит, 15 символов будут "весить" 15х4=60 бит.

Шаг 4.

1 пароль по условию кодируется минимально возможным целым количеством байт.

Сколько байт нужно для хранения пароля из 60 бит?

7 байт мало, так как 7 байт = 7х8 = 56 бит.

8 байт — в самый раз: 8 байт = 8х8=64 бита.

Следовательно, для хранения одного пароля нужно 8 байт.

Шаг 5

Один пароль "весит" 8 байт.

У нас — 20 пользователей (и 20 паролей соответственно).

Следовательно, они "весят" 8х20 = 160 байт.

Шаг 6

Выделено было 400 байт под пароли.

Чисто на хранение, согласно п.5, было использовать 160 байт.

Значит, осталось на дополнительную информацию300-160=140 байт.

Шаг 7

140 дополнительных байт имеется подо все пароли.

Всего паролей — 20.

Значит, под каждый дополнительно выделяется 140/20=7 байт.

ответ: по 7 байт дополнительно выделено для хранения одного пароля.

Объяснение:

ostapbender1111
Using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;

namespace pzn
{

    class Program
    {
       public static void Main(string[] args)
        {
            int x = Convert.ToInt32(Console.ReadLine());
            int y = Convert.ToInt32(Console.ReadLine());
            int temp;
            if (x<y)
            {
                x ^= y;
                y ^= x;
                x ^= y;    
            }
            Console.WriteLine("x={0}, y={1}", x, y);
            Console.ReadKey();
        }
    }
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу которая считывает 6 чисел и найти сумму неотрицательных чисел.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

eidevyatkina
Aleksandrovich_Mitoyan1138
best00
Владислав-Аветисян217
Lyalikova
jeep75
Андреевич-Екатерина1974
pelagia-kola2658
Linichuk
abroskin2002
uttgroup
jim2k
Sergeevich-irina
rayman777
alexeytikhonov