museumuzl
?>

Составить программу, которая находит сумму остатков от деления на 3 всех чисел от 1 до 100

Информатика

Ответы

snabdonm501

#include <iostream>

using namespace std;

int main ()

{

int sum=0;

for (int i=1; i<=100; i++)

sum+=i%3;

cout<<sum;

return 0;

}

char40

Я бы посоветовал вместо прямого перевода 2 <-> 10 работать через 16ричную систему счисления. Алгоритмы те же, вычислений меньше, значит меньше и ошибок. А двоичные значения 16 цифр очень легко запомнить.

Гляди, как просто получится

1.

96 = 60h = 0110 0000b

53 = 35h = 0011 0101b

74 = 4Ah = 0100 1010b

80 = 50h = 0101 0000b

122=7Ah=  0111 1010b

 

2.

   1010011b = 0101 0011b = 53h = 5*16+3=83

   10011101b= 1001 1101b = 9Dh = 9*16+13 = 157

   11011111b= 1101 1111b = DFh = 13*16+15= 223

 

3.

  1010011b +   110101b = 0101 0011b + 0011 0101b = 53h + 35h = 88h = 1000 1000b

11011111b + 1111010b = 1101 1111b + 0111 1010b =  DFh+7Ah = 159h= 0001 0101 1001b

 

 

Замечание1. Для решения последнего примера нужно, конечно, знать таблицу сложения 16-ричных цифр.

 

Замечание2 Напомню перевод 10 ->16, повторюсь, алгоритм тот же, что и 10->2

Например

122/16 = 7 (ост 10), значит 122=7Аh

 

Замечание3 И последнее, в практической деятельности 2-ичная система практически не используется, профессионалы, если нужно, работают с 16-ричной(это связано с тем, что байт, так уж случилось, равен 8 бит).

 

Ну, вроде всё.

 

Иванов1813
function ptcrk(a,b,x,y,r: real): integer;
var k: integer;
begin
  k:=0;  
  if abs(sqr(x-a)+sqr(y-b)-r*r)<1.0e-9 then k:=1;
  if r*r-sqr(x-a)-sqr(y-b)>1.0e-9 then k:=2;
  ptcrk:=k;
end;
// основная программа
var a,b,x,y,r,k: real;
begin
  write('координаты центра a b: ');  readln(a,b);
  write('координаты точки x y: ');  readln(x,y);
  write('радиус: ');  readln(r);
  k:=ptcrk(a,b,x,y,r);
  if k=1 then writeln('точка на окружности');
  if k=2 then writeln('точка внутри круга');
  if k=0 then writeln('точка вне круга');
end.

координаты центра a b: 2 1
координаты точки x y: 4 1
радиус: 2.1
точка внутри круга

координаты центра a b: 2 1
координаты точки x y: 4 1
радиус: 2
точка на окружности

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу, которая находит сумму остатков от деления на 3 всех чисел от 1 до 100
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Alesander-Isaev684
klimenokvapeshop1408
anchutk3016
kapi30
Liliya-buc
Aivazyan
krimenu5033
ibombenkova
Galkin Vladimirovich729
director
Nv-444
Zeitlinama7067
ilyagenius
Anatolevich
sedalex
▲