VladimirovnaKashintsev1151
?>

Разработать блок схему, составить программу, произвести отладку и тестирование: для вычисления силы f, которая действует на тело массой m, которое движется с ускорением a (формула f=ma)

Информатика

Ответы

ski89439

Var m,a, F: Integer;

begin

writeln('Введите значени m');

readln(m);

writeln('Введите значение a');

readln(a);

F:=m*a;

writeln('ответ, F = ', F);

readln;

end.



Разработать блок схему, составить программу, произвести отладку и тестирование: для вычисления силы
nevzorova

Красные - не соответствуют требованию

Зелёные - соответствуют

Решается по такому принципу: берётся любая клетка на поле и прогоняется через программу. Как работает программа: если внизу свободно, спускаемся вниз до того момента, пока это возможно, затем, если свободно справа - двигаемся вправо пока это возможно. Далее всё повторяется до тех пор, пока мы не окажемся в необходимой нами клетке, либо в тупике (то есть тупиком в данном случае является ситуация, когда и снизу, и справа стена)

Клеток, удовлетворяющих условию оказалось 22.

ответ: 22


выполнить, уже совсем запутался
turovvlad

#include

#include

#include

#include

#include

#include

typedef struct

{

char imya[40];

char familiya[40];

char otchestvo[40];

int telefon;

int texpasport;

float pages ;

}gor;

void form(char mass[10], char *imya, char *familiya, char *otchestvo, int telefon, int texpasport)

{

file *f;

gor y;

int i;

if ((f=fopen(mass,"w"))==null) exit(1);

for (i=1; i< =3; i++)

{

cout< < "vvedite imya: ";

cin> > imya;

cout< < "vvedite familiya: ";

cin> > familiya;

cout< < "vvedite otchestvo: ";

cin> > otchestvo;

cout< < "vvedite telefon: ";

cin> > telefon;

cout< < "vvedite texpasport: ";

cin> > texpasport;

fwrite(& y,sizeof(gor),1,f);

if(ferror(f)! =null)

exit(2);

}

fclose(f);

}

void vivod(char mass[50])

{

file *f;

gor z;

if ((f=fopen(mass, "r"))==null) exit(3);

cout< < "fail: "<

while (! feof(f)) {

fread (& z,sizeof(gor),1,f);

if (! feof(f))

{

cout< < "imya: "<

cout< < "familiya: "<

cout< < "otchestvo: "<

cout< < "telefon: "<

cout< < "texpasport: "<

}

fclose(f);

}

}

void del(char fo[10], char fi[10])

{

file *f1,*f2;

gor d;

//char temp[40];

if ((f1=fopen(fi,"r"))==null) exit(4);

if ((f2=fopen(fo,"w"))==null) exit(5);

//cout < < "vvedite nazvanie na ydalenie - ";

//cin > > temp;

for (int i=0; i< 3; i++)

{

fread(& d,sizeof(gor),1,f1);

if (feof(f1)) break;

if (i> 2)

fwrite (& d,sizeof(gor),1,f2);

}

fclose(f2);

fclose(f1);

}

void dobav(char fi[10], char fo[10],char *imya, char *familiya, char *otchestvo, int telefon, int texpasport)

{

int q;

int i;

gor d;

file *f1,*f2;

char temp[40];

if ((f1=fopen(fi, "r"))==null) exit(4);

if ((f2=fopen(fo,"r+"))==null) exit(5);

cout < < "vvedite familiu, pered kotorym nuzno dobavit element: ";

cin > > temp;

for (i=0; i< 10; i++)

{

fread(& d,sizeof(gor),1,f2);

if (feof(f2)) break;

if (strcmp(d.familiya, temp)) break;

q=i;

}

for (i=0; i< 10; i++)

{

if (feof(f2)) break;

fwrite (& d,sizeof(gor),1,f2);

if (i==q-1)

{

cout< < "vvedite imya: ";

cin> > imya;

cout< < "vvedite familiya: ";

cin> > familiya;

cout< < "vvedite otchestvo: ";

cin> > otchestvo;

cout< < "vvedite telefon: ";

cin> > telefon;

cout< < "vvedite texpasport: ";

cin> > texpasport;

cout <

}

}

fclose(f2);

fclose(f1);

}

void main()

{

int n=10;

//cout < < "vvedite kol-vo zapisey: - ";

//cin> > n;

//cout <

form("f1.txt",n);

vivod("f1.txt");

del("f1.txt","f2.txt");

cout < < "posle udalenia: \n";

vivod("f2.txt");

getch();

n=1;

system("cls");

dobav ("f2.txt","f2.txt");

cout < < "posle dobavlenia: \n";

vivod ("f2.txt");

getch();

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Разработать блок схему, составить программу, произвести отладку и тестирование: для вычисления силы f, которая действует на тело массой m, которое движется с ускорением a (формула f=ma)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Ushakova Sakhno
fellybrossme
ooost-2022
Drugov_Vladimirovna
Paradismebel
ИвановнаВладимир1832
Ushakova Sakhno
kbndbyb6
yna21289
abroskin2002
minasov19
fedserv
olarina6510
alexey
vladimir686