kamalfayed229
?>

Написать программу, которая в качестве результата дает истину, если выполняется заданное условие, или ложь, если условие не выполняется: введенное целое число является квадратом нечетного числаmathcad)

Информатика

Ответы

gip5362

/


Welcome to GDB Online.

GDB online is an online compiler and debugger tool for C, C++, Python, Java, PHP, Ruby, Perl,

C#, VB, Swift, Pascal, Fortran, Haskell, Objective-C, Assembly, HTML, CSS, JS, SQLite, Prolog.

Code, Compile, Run and Debug online from anywhere in world.


/

#include <stdio.h>

#include <iostream>

#include <math.h>

int main()

{

  int x=0;

 std::cin >> x;

  int tmp = round(sqrt(x));

if (sqrt(x) == tmp && tmp % 2 != 0){

   std::cout << true;

}

else{

   std::cout << false;

}

   return 0;

}

olarina6510
Сумма номеров от 1 до 9 равна 45.
Сумма от 10 до 19 равна 10 + 45 = 55.
Сумма от 20 до 29 равна 2*10 + 45 = 65.
Сумма от 30 до 39 равна 3*10 + 45 = 75.
...
Сумма от 90 до 99 равна 9*10 + 45 = 135.
Сумма всех цифр от 1 до 99 равна
45 + 55 + 65 + ... + 135 = (45 + 135)*10/2 = 180*10/2 = 900
В номерах от 100 до 199 та же сумма цифр 900 + 100*1 = 1000
В номерах от 200 до 209 сумма цифр 2*9 + 45 = 18 + 45 = 63
В номерах от 210 до 212 сумма цифр 2+1+0+2+1+1+2+1+2 = 12
Итого сумма всех цифр 900 + 1000 + 63 + 12 = 1975
myglassi26
Предполагаю 55555 - 29 - Ы
мой вариант - немного не логичный с некоторой стороны, но попытаюсь объяснить почему 29:
--
О - 16 - 10000 в двоичной системе, если посмотреть, то именно 5 цифр получается, что возможно нам и подходит.
Д - 5 - 101 возможно, это потому что две 55, и добавляем единицу в конце
Т - 20 - 10100 тут образуются все 5 цифр, и как перед этим (Д - 5), получаем 101
Ч - 26 - 11010 тут просто добавляется 1 в перед
и далее 55555, так как с 5555 получили просто впереди 1, то скорее всего, и тут добавляется 1, и получаем число 11101 = 29

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая в качестве результата дает истину, если выполняется заданное условие, или ложь, если условие не выполняется: введенное целое число является квадратом нечетного числаmathcad)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

k075ko8
kettikis
germanleon
isaev
Анатольевна
aetolstih
ikosheleva215
guzelda19904850
vitaldicky349
pri02
svo1961
Тимур Андраниковна634
pavlova7771960
natkuv7
Pavlushina-Novikova