Так как в условии не написано про язык, напишу на C++
gaydukov5706
17.09.2022
const handsfree = false;
var a: array[1..100] of real; i, n: integer; sum_pos, sum_neg: real; k_pos, k_neg: integer;
begin {ввод массива} if handsfree then n := random(20) + 5 else begin write('n = '); readln(n); end;
writeln('Данные массива:'); for i := 1 to n do begin if handsfree then begin a[i] := random(100) - 50; write(a[i], ' '); end else readln(a[i]); end; writeln();
{подсчет} sum_pos := 0; k_pos := 0; sum_neg := 0; k_neg := 0; for i := 1 to n do begin if a[i] > 0 then begin sum_pos := sum_pos + a[i]; k_pos := k_pos + 1; end;
Const n=5; var a:array[1..n,1..n] of integer; i,j:integer;
begin //генератор случайных чисел. Диапазон от 1 до 10. for i:=1 to n do begin for j:=1 to n do begin a[i,j]:=random(10)+1; write(a[i,j]," "); end; writeln(); end;
//Проверка условия и переприсвоение, если верно. for i:=1 to n do for j:=1 to n do begin if (((i+j) mod 2)=0) then a[i,j]:=a[1,2]; end;
//Вывод полученного массива. for i:=1 to n do begin for j:=1 to n do begin write(a[i,j]," "); end; writeln(); end;
//Ожидание. readln(); end.
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Напишите программу, в которой определяется количество элементов массива, кратных 5