director
?>

Составить программу в pascal, которая будет рисовать на экране инициалы х.c.в с линий и дуг

Информатика

Ответы

Скворцов

uses GraphABC;

begin  

Line(50,140,200,340);  

Line(200,140,50,340);  

Line(205,340,205,335);

Line(205,335,210,335);

Line(210,335,210,340);

Line(205,340,210,340);

arc (316,240,100,55,305);

arc (377,340,3,0,360);

Line(400,140,400,340);  

Line(400,140,500,140);

Line(400,240,500,240);  

Line(400,340,500,340);

arc (500,190,50,450,270);

arc (500,290,50,450,270);

end.

Александровна1685
Только программа, блок-схему не знаю
#include <iostream>
#include <iomanip>
#include <vector>
#include <ctime>
int main()
{
    using namespace std;

    const int n = 5;
    int A[n][n];
    int D[n][n];
    vector<int> B(n);
    vector<int> C(n);
    vector<int> S(n);   //результирующий вектор

    //как-нибудь заполняем исходные матрицы и вектора
    srand(time(0));
    for (int i = 0; i < n; ++i)
    {
        for (int j = 0; j < n; ++j)
        {
            A[i][j] = rand() % (n * n) - n * n / 2;
            D[i][j] = rand() % (n * n) - n * 2;
        }
        B[i] = rand() % (n * n) - n;
        C[i] = rand() % (n * n) - n * n + n;
    }

    //выведем исходные данные на экран
    cout << "matrix A:\n";
    for (int i = 0; i < n; ++i)
    {
        for (int j = 0; j < n; ++j)
            cout << setw(5) << A[i][j];
        cout << endl;
    }

    cout << "\nmatrix D:\n";
    for (int i = 0; i < n; ++i)
    {
        for (int j = 0; j < n; ++j)
            cout << setw(5) << D[i][j];
        cout << endl;
    }

    cout << "\nvector B:\n";
    for (int i = 0; i < n; ++i)
        cout << setw(5) << B[i] << endl;

    cout << "\nvector C:\n";
    for (int i = 0; i < n; ++i)
        cout << setw(5) << C[i] << endl;

    //вычислим требуемое
    for (int i = 0; i < n; ++i)
    {
        S[i] = 0;
        for (int j = 0; j < n; ++j)
            S[i] += D[i][j] * C[j];
        S[i] += 3 * B[i];
    }

    //выведем результат на экран
    cout << "\nvector S = D * C + 3 * B:\n";
    for (int i = 0; i < n; ++i)
        cout << setw(5) << S[i] << endl;

    return 0;
}
brovkinay
1) файл паскаля приложен.
2) код на c#
        static void Main(string[] args)        {            int a, b;            a = Convert.ToInt32(Console.ReadLine());            b = Convert.ToInt32(Console.ReadLine());            if (a > 2)            {                Console.WriteLine(a / 2);                Console.WriteLine(b - 1);            }        }
3) Код на vb
dim a as integer = 0
dim b as integer = 0
a = cint(console.readline())
b = cint(console.readline())
if a > 2 then
console.writeline( a / 2)
console.writeline(b - 1)
end if

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу в pascal, которая будет рисовать на экране инициалы х.c.в с линий и дуг
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

mereninka7008
agusarevich283
machkura
serkinn69
zloshop9
Koshkina Alekseevna
Михайлов
Chernaya
vladburakoff5
kronid12
Геннадьевна Вета560
mila-vsv
siren89
Olenkalebedeva4477
ashkiperova6
▲