Igor1406
?>

Pascal abc/ c клавиатуры вводят два слова. составить программу, которая проверяет, не начинается ли второе слово с той же буквы, которой оканчивается первое слово

Информатика

Ответы

mila-vsv

var s1,s2: string;

begin

writeln('Введите 2 слова:');

readln(s1);

readln(s2);

if s1[length(s1)]=s2[1]

then writeln('второе слово начинается с той же буквы, которой оканчивается первое слово')

else writeln('последняя буква первого слова отличается от первой буквы второго слова');

end.



Pascal abc/ c клавиатуры вводят два слова. составить программу, которая проверяет, не начинается ли
anastasiya613
// PascalABC.NET 3.0, сборка 1144 от 16.01.2016
begin
  var a:=ArrRandom(100,-10,10);
  a.Println;
  Writeln(a.Where(x->x>0).Count,' положительных, ',
    a.Where(x->x<0).Count,' отрицательных')
end.

Тестовое решение:
4 -6 0 8 2 -2 -1 -8 -6 8 -3 7 4 -7 -5 9 0 -3 -7 1 0 -4 6 3 8 -10 4 9 3 5 8 5 5 8 10 4 -8 3 8 8 -9 2 7 -8 -7 -5 2 -9 0 9 -7 7 -2 -6 7 -2 -1 7 -10 2 4 1 -1 0 10 3 -8 6 -6 2 6 7 -1 -4 -1 8 0 3 0 2 -2 2 -1 5 1 -9 -4 1 -9 1 -6 -5 3 -4 -7 1 -7 -3 -7 1
51 положительных, 42 отрицательных
lugowskayatania2017
1.
var
  s: string;
  i, count: integer;
begin
  writeln('Vvedite stroky: ');
  readln(s);
  for i := 1 to length(s) - 2 do
    if copy(s, i, 3) = 'abc' then
      count := count + 1;
  writeln('Kol-vo: ', count);
end.
2.
var
  s1, s2: string;
  i, len1, len2: integer;
begin
  writeln('Vvedite stroky 1: ');
  readln(s1);
  writeln('Vvedite stroky 2: ');
  readln(s2);
  len1 := length(s1);
  len2 := length(s2);
  if len1 > len2 then writeln('1 stroka dlinnee')
  else if len1 < len2 then writeln('2 stroka dlinnee')
  else writeln('dlini strok ravnie')
end.
3.
var
  s1, s2, s3: string;
begin
  writeln('Vvedite stroky 1: ');
  readln(s1);
  writeln('Vvedite stroky 2: ');
  readln(s2);
  s3 := s1[1] + s1[2] + s2[1] + s2[2];
  writeln('Novaja stroka: ', s3);
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Pascal abc/ c клавиатуры вводят два слова. составить программу, которая проверяет, не начинается ли второе слово с той же буквы, которой оканчивается первое слово
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Исакова-Александрович511
irkm8
Belov Yekaterina639
abuley
ЕленаАнастасия315
nyuraborova89
хаджимурод1172
koptevan6
adminkuncevo
shurshin6975
reception
Vera-zero281
inna-zub
rudakovam198
▲