Const nx=30;var i,j,p,n:integer;A:array[1..nx,1..nx] of integer;d,Sn,min:real;begin p:=1;write('Введите размер матрицы');Read(n);for i:=1 to n do beginfor j:=1 to n do beginA[i,j]:=random(3)-2;write(A[i,j]:4);end;writeln;end;writeln;writeln;for i:=1 to n do beginfor j:=1 to n do beginif i = j then begin if A[i,j]<> 0 then p:=p* A[i,j];write(A[i,j]:4);endelse write(' ':4);end;writeln;end;write('p =',p);writeln;writeln;for i:=1 to n do beginfor j:=1 to n do beginif (i= n -j +1) then begin if A[i,j]<> 0 then p:=p* A[i,j];write(A[i,j]:4);endelse write(' ':4);end;writeln;end;write('p =',p);end.
Mariya dmitrievna
27.05.2023
Ультразвуковой датчик-это специальный инструмент, используемый для измерений в промышленной автоматизации. С его можно измерять расстояние, высоту и уровень, а также определять положение в пространстве, обнаруживать наличие объектов и даже подсчитывать их по отдельности. Ультразвуковые датчики содержат ультразвуковые преобразователи . Преобразователь может преобразовывать одну форму энергии в другую. Датчик является причиной, по которой датчик может излучать звуковой импульс. Затем создается эхо, когда излучаемый импульс отражается от объекта.
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Составить программу, которая определяет, какое из двух введенных с клавиатуры слов разной длины более длинное, и выводит это слово. паскаль абц
Program z567;
Var s_1,s_2:string; l,l_1:integer;
Begin
write('Введите 1-ое слово - '); readln(s_1);
write('Введите 2-ое слово - '); readln(s_2);
if (s_1.Length > s_2.Length) then writeln(s_1)
else writeln(s_2);
End.