Mariya694
?>

Составьте программу которая формирует массив из пятнадцати случайных чисел от -20 до 20 и увеличивает в два раза числа кратные пяти, а остальные уменьшает в два раза

Информатика

Ответы

olgaprevisokova302

const n=15;

var a:array [1..n] of integer;

b:array [1..n] of real;

i:integer;

begin

write('       Исходный массив: ');

for i:=1 to n do

begin

a[i]:=random(41)-20;

write(a[i]:5);

if a[i] mod 5 = 0 then b[i]:=a[i]*2

else b[i]:=a[i]/2

end;

writeln;

write('Преобразованный массив: ');

for i:=1 to n do write(b[i]:5);

end.

efimov33

Объяснение:

Первоначальный размер = 16386 бит = 2048,25 байт = 2 кб;

512 байт = 0,5 кб

1 компьютер = 2 + 1,5 КБ = 3,5 кб

2 компьютер = 3,5 + 0,5 КБ = 4 кб

3 компьютер = 4 + 10 = 14 кб

4 компьютер = 14 + 1,5 = 15,5 кб

5 компьютер = 15,5 + 0,5 = 16 кб

6 компьютер = 16 + 10 = 26 кб

7 компьютер = 26 + 1,5 = 27,5 кб

8 компьютер = 27,5 + 0,5 = 28 кб

9 компьютер = 28 + 10 = 38 кб

10 компьютер = 38 + 1,5 = 39,5 КБ (не учитывается по условию)

Или проще :

Заразив три компьютера, он увеличивается на 12 КБ.

3 компьютера = 2 + 12 = 14 кб

6 компьютеров = 14 + 12 = 26 кб

9 компьютеров = 26 + 12 = 38 кб

10-ый = 38 + 1,5 = 39,5 не учитывается

Владимир1524

Объяснение:

Первоначальный размер = 16386 бит = 2048,25 байт = 2 кб;

512 байт = 0,5 кб

1 компьютер = 2 + 1,5 КБ = 3,5 кб

2 компьютер = 3,5 + 0,5 КБ = 4 кб

3 компьютер = 4 + 10 = 14 кб

4 компьютер = 14 + 1,5 = 15,5 кб

5 компьютер = 15,5 + 0,5 = 16 кб

6 компьютер = 16 + 10 = 26 кб

7 компьютер = 26 + 1,5 = 27,5 кб

8 компьютер = 27,5 + 0,5 = 28 кб

9 компьютер = 28 + 10 = 38 кб

10 компьютер = 38 + 1,5 = 39,5 КБ (не учитывается по условию)

Или проще :

Заразив три компьютера, он увеличивается на 12 КБ.

3 компьютера = 2 + 12 = 14 кб

6 компьютеров = 14 + 12 = 26 кб

9 компьютеров = 26 + 12 = 38 кб

10-ый = 38 + 1,5 = 39,5 не учитывается

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу которая формирует массив из пятнадцати случайных чисел от -20 до 20 и увеличивает в два раза числа кратные пяти, а остальные уменьшает в два раза
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

bessalaias
Sergei1805
rsksnb
diana-kampoteks
Александрович686
Grishanin
kategar
Narine natalya
Sergei_sergei
kim-1971
Роман1406
slonikkristi69
okasnab
TSKaraulova
iuv61