Ubuleeva826
?>

Заданы два числовых массива (стека) одинаковой длины с целыми числами. составьте программу с которой можно: 1) все числа из первого массива переписать во второй массив и вывести на экран три массива ( два исходных и результат)

Информатика

Ответы

alyonazharikowa4

const n=10;

var a,b:array[1..n] of integer;

i: integer;

begin

for i:=1 to n do

begin

a[i]:=random(10);

write (a[i]:3)

end;

writeln;

for i:=1 to n do

begin

b[i]:=random(10);

write (b[i]:3)

end;

writeln;

for i:=1 to n do

begin

b[i]:=a[i];

write (b[i]:3)

end;

writeln;

end.

amarantmetall
// PascalABC.NET 3.0, сборка 1076
type
  Point=record
  x,y:real
  end;
  Line=record
  A,B:Point
  end;
  Triangle=record
  A,B,C:Point;
  sa,sb,sc:real; { длины сторон }
  end;

procedure GetPoint(PointName:char; var M:Point);
begin
  Write('Введите координаты точки ',PointName,'(x,y): ');
  Read(M.x,M.y)
end;

function LineLength(A,B:Point):real;
begin
  LineLength:=sqrt(sqr(B.x-A.x)+sqr(B.y-A.y))
end;
 
procedure CreateTriangle(var T:Triangle; var l:boolean);
begin
  With T do begin
    GetPoint('A',A);
    GetPoint('B',B);
    GetPoint('C',C);
    sa:=LineLength(B,C);
    sb:=LineLength(A,C);
    sc:=LineLength(A,B);
    l:=(sa+sb>sc) and (sa+sc>sb) and (sb+sc>sa)
  end
end;

function TriangleIsLikes(T1,T2:Triangle):boolean;
var
  k1,k2,k3:real;
begin
  k1:=T1.sa/T2.sa; k2:=T1.sb/T2.sb;
  if k1=k2 then begin
    k3:=T1.sc/T2.sc;
    TriangleIsLikes:=k1=k3
    end
  else
    TriangleIsLikes:=False
end;

var
  T1,T2:Triangle;
  legal:boolean;
begin
  Writeln('*** Первый треугольник ***');
  CreateTriangle(T1,legal);
  if legal then begin
    Writeln('*** Второй треугольник ***');
    CreateTriangle(T2,legal);
    if legal then
      if TriangleIsLikes(T1,T2) then Writeln('Треугольники подобны')
      else Writeln('Треугольники не подобны')
    else Writeln('Треугольник невозможно построить')
    end
  else Writeln('Треугольник невозможно построить')
end.
Natella-874535
Тут особо можно не думать. Замечаем, что в результате надо получить значение А⊕ Ā в восьмиразрядном представлении. Результат такой операции - всегда все единицы во всех разрядах. А разрядов эти по условию 8.

Если формат знаковый, то старший разряд, равный 1 означает, что число отрицательное, а они обычно хранятся в дополнительном коде. Для перевода в основной код инвертируем  все разряды, кроме старшего знакового. Получаем семь нулей. И прибавляем единицу, окончательно получая 10000001, т.е. -1 в двоичной системе. В десятичной системе (как и в любой другой с натуральным основанием, единица - всегда единица.

ответ: -1

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Заданы два числовых массива (стека) одинаковой длины с целыми числами. составьте программу с которой можно: 1) все числа из первого массива переписать во второй массив и вывести на экран три массива ( два исходных и результат)
Ваше имя (никнейм)*
Email*
Комментарий*