drontox1031
?>

Написать программу 1 – у пользователя запрашиваются 6 элементов массива целых чисел. 2 – на экран выводится все 6 элементов массива, каждый из них на 1 (единицу) больше введенного. пример: ввели a[1] = 4, a[2]= 7, … вывод на экран: a[1] = 5, a[2] = 8, …

Информатика

Ответы

Goldaram84

var a: array [1..6] of integer;

i: byte;

begin

for i:=1 to 6 do begin

write('Введите элемент a[',i,']: ');

readln(a[i]);

end;

writeln('Исходный массив');

for i:=1 to 6 do begin

writeln('a[',i,'] = ',a[i]);

a[i]:=a[i]+1;

end;

writeln('Преобразованный массив');

for i:=1 to 6 do

writeln('a[',i,'] = ',a[i]);

end.

Щербаков33
Код#include <iostream>constexpr double bites_to_megabytes(double a) {    return a / 8388608;}constexpr double megabytes_to_gigabytes(double a) {    return a / 1024;}int main() {    long long a;    short type;    bool is_correct = false;    double answer;    do {        std::cin >> a;        std::cout << "[1] Megabytes \n"                  << "[2] Gigabytes \n"                  << "Convert to [1] or [2]: ";        std::cin >> type;        if (type == 1 or type == 2) {            is_correct = true;        } else {            std::cout << "Meh. Try to type again. \n" << std:: endl;        }    } while (!is_correct);    switch (type) {        case 1:            answer = bites_to_megabytes(a);            break;        case 2:            answer = megabytes_to_gigabytes(bites_to_megabytes(a));            break;    }    std::cout << "An answer of conversion is " << answer << std::endl;    return 0;}
Merkuloff78
В начале мы создаем массив случайных элем.
Потом работаем с ним.
Нам нужны 2 переменные:
1 - переменная, для сохранения результата (номера).
2 - переменная флажок.
Мы обходим весь массив ПО СТОЛБЦАМ.
В начале обхода конкретного столбца переменной флажка присвоим 1.
Сравниваем текущий элемент столбца с последующим,
если они не равны то ставим флажок 0

Код:
//Размерность массива
const n = 3;
//Сам массив
var 
ar : array[1..n,1..n] of integer;
//Переменные для работы с массивом
var 
i,j : integer; 
//Переменные для поиска столбца
//f - переменная флажок, которая по окончанию обхода столбца будет
//показывать одинаковы ли элементы в нем
//numb - переменная, в которой сохраним номер столбца с
//одинаковыми значениями элементов.
var 
f,numb : integer;
begin
//Создание и вывод на экран массива
//Элементы генерируются случайным образом
//  
for i:=1 to n do 
begin   
for j:=1 to n do   
begin     
ar[i,j] := random(2);     
write(ar[i,j]:3);   
end;   
writeln;   
end;  
// 

//Вот сам алгоритм поиска
//
//Записываем в numb значение -1
//Если в процессе работы значение не изменится (-1)
//То означает, что в массиве нет одинаковых столбцов
  numb := -1; 

//Идем по массиву
//
for j:=1 to n do
//Момент начала конкретного j столбца  
  begin    
//записываем в f значение 1
  //Предполагаем, что столбец одинаков
  //Если в конце обхода конкретного столбца значение f=1
  //Значит, что данный столбец одинаков
  f := 1;    
 
//Идем по столбцу
// n-1
//(т.к сравниваем текущий со следующим)
for i:=1 to n-1 do   
begin  
//Сравниваем текущий элемент столбца, со следующим     
if (ar[i,j] <> ar[i+1,j]) then
    //Если они не равны, то изменяем значение флажка f на 0       
    f := 0;   
end; 
//Конец обхода конкретного столбца  
 
//Если столбец одинаков   
if (f = 1) then
    //то записываем его номер в numb     
    numb := j;  
end;  
//  

//Вывод результата 
if (numb <> -1) then   
writeln('Столбец №: ',numb) 
else   
writeln('Нет ни одного одинакового столбца');    
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу 1 – у пользователя запрашиваются 6 элементов массива целых чисел. 2 – на экран выводится все 6 элементов массива, каждый из них на 1 (единицу) больше введенного. пример: ввели a[1] = 4, a[2]= 7, … вывод на экран: a[1] = 5, a[2] = 8, …
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Shtorm-Shoe
oksanashabanovadc3197
Irina_Nikolai
milanparipovic864
annino
lenapopovich556510
Vladimirovna1370
Галина-Юлия1292
fakyou170
Палкина-Дроздова
ksoboleva
alenchik19938823
annaan-dr582
ИП-Сысоев1628
zibuxin6