helenavalenti2846
?>

Напишите программу для создания массива а из десяти целых чисел, элементы которого вводятся с клавиатуры. в программе подсчитать k - количество элементов массива, значение которых превышает 12.

Информатика

Ответы

АлександрАлина

var

 a: array[0..9] of integer;

 k, i: integer;

 

begin

 k := 0;

 for i := 0 to 9 do  

 begin

   readln(a[i]);

   if a[i] > 12 then k += 1;

 end;

 writeln(k);

end.

Maksimova1320
Функция isSevenHere возвращает истину, если в числе есть семерка, и ложь - если ее нет. В цикле for перебираем все значения от 1 до K (число, введенное с клавиатуры), и выводим на экран только те, где есть семерка.

Код программы:

function isSevenHere(number : integer) : boolean;var digit : integer;begin  Result := true;  while (number > 0) do  begin        digit := number mod 10;    if (digit = 7) then            exit;    number := number div 10;  end;  Result := false;end;
var i,k :integer;begin  write('Введите k: ');  readln(k);
  for i := 1 to k do    if (isSevenHere(i) = true) then      write(i,' ');end.
Найти и вывести на экран все целые числа из промежутка от 1 до k, в десятичной записи которых есть ц
Sergei_sergei

Program mathlover12;

const

 n = 6; {Количество элементов массива}

var  

 a:array[1..n] of integer;

s:string;

i,min,max: integer;

begin

 s:=' -=Alphaeus=- ';

 for i:=1 to 22 do begin write(s[i]); sleep(42) end;

{вводим элементы массива}

 writeln; writeln('Введите ',n,' чисел:');

 for i:=1 to n do read(a[i]);

{Ищем min и max}

min:=a[1];

max:=a[1];

 for i:=2 to n do

   begin

     if min>a[i] then min:=a[i];

     if max<a[i] then max:=a[i];

   end;

{Выводим произведение  min и max}

 writeln; writeln;

 writeln('Произведение min и max равнo ',min*max);

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу для создания массива а из десяти целых чисел, элементы которого вводятся с клавиатуры. в программе подсчитать k - количество элементов массива, значение которых превышает 12.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

itartdesignprof
dmitryshigin
dearmaria
vyborovvs
Romanovich1658
Voronin-Albertovich
mustaevdmitry397
leeteukism
tkozina
vera-spicina
bas7572513
madjk
Vetroff-11
vikabobkova2010
denchiklo2299667