I.B.Petrishchev
?>

Укого с информатикой хорошо? 9 класс написать программу для нахождения минимального элемента массива а(21 написать программу, находящую номер первого и последнего отрицательного элементов массива y(25). вычислить среднее арифметическое положительных четных элементов массива а(n).

Информатика

Ответы

varvara-kulkova

#1


var

A : array [1..21] of integer;

min : integer := 32766;

begin

for var i:=1 to 21 do

 readln(A[i]);

for var i:=1 to 21 do

if (A[i] < min) then

min := A[i];

writeln(min);

end.

#2

var

Y : array [1..25] of integer;

isthefirst : boolean := false;

last : integer := 0;

begin

for var i:=1 to 25 do

 readln(Y[i]);

for var i:=1 to 25 do

 if (Y[i] < 0) and (isthefirst = false) then

   begin

   writeln(i);

   isthefirst := true;

   break;

   end;

for var i:=2 to 25 do

begin

if (i = 25) then  

begin

if (Y[i] < 0) and (last = 0) then

last := i;

break;

end;

if ((Y[i+1] > 0) and (Y[i] < 0)) then

last := i;

end;

if (isthefirst) and (last = 0) then

last := 1;

if (last <> 0) then

writeln(last) else

writeln('There''no numbers');

end.

//Не бейте за кастыли Мне лень думать)))000



#2

type TIntMassiv = array of Integer;   //Дин. Массив (Более гибок в работе)


var  

n : integer;

sum : integer := 0;

counter : integer := 0;

var A: TIntMassiv;

begin

readln (n);

SetLength(A, n);

for var i:=0 to n-1 do

begin

readln(A[i]);

if (A[i] > 0) and (A[i] mod 2 = 0) then

begin

sum += A[i];

counter += 1;

end;

end;

if (sum = 0) or (counter = 0) then

begin

writeln('There''re no numbers');

exit;

end;

writeln(sum/counter);

end.

Peshkov
1. Телевизор — это относительно сложная техническая сис­тема. Но только подключенный к системе телевещания он становится подсистемой информационной системы.
2. Велосипед — техническая система. Велосипедист, ката­ющийся на велосипеде, составляет с ним простую социо-техническую информационную систему. Ее информаци­онный характер обусловлен тем, что в процессе езды велосипедист получает и обрабатывает информацию о со­стоянии внешней среды и самой системы (препятствия на дороге, наличие автомобилей или других велосипеди­стов, сила ветра, собственная усталость, исправность уз­лов велосипеда и пр.) и использует ее для регулирования и направления поведения системы.
3. Аппаратная часть компьютера — достаточно сложная техническая система, но только в совокупности с про­граммным обеспечением она представляет собой инфор­мационную техническую систему. Система, состоящая из компьютера и работающего с ним пользователя, отно­сится уже к классу информационных социотехнических систем.
4.Информационная система банка обеспечивает все виды оплат по счетам его клиентов. Она умышленно сделана несовместимой с информационными системами других банков. Таким образом, клиент попадает в круг услуг банка, из которого ему трудно выйти. В обмен банк предлагает ему различные скидки и бесплатные услуги.
5. Информационные система по продаже авиабилетов позволяет проанализировать архивные данные за многие годы, оценить перспективы наполнения салона, назначить разумную цену на каждое место, снизить количество не проданных билетов и пр. Она резервирует каждое место на самолет в США за три месяца до полета 1,5 раза, т.е. два места резервируются за тремя пассажирами.
inj-anastasia8
Допустим, мы ведем счет дней недели с воскресенья и присваиваем дням такие номера:
0- Вс, 1- Пн, 2- Вт, 3- Ср, 4- Чт, 5- Пт, 6- Сб.
Определим, когда в январе было первое Вс.
Если 31 был Пн, то 4 недели назад, т.е. 31-28=3 числа тоже был Пн.
А Вс было перед Пн, т.е. 2 января.
Числа от 0 до 6 - это остатки целочисленного деления на 7.
Получается, что остаток деления числа 2 на 7, должен привести нас к нулю. А он равен двум.
Идея: вычтем из остатка 2, чтобы получился ноль.
Идея хороша для остатка 2, 3, 4, 5, и 6. Она даст нам значения 0, 1, 2, 3 и 4. А вот для остатков 0 и 1, она даст -2 и -1, что нехорошо.
Внесем корректировку. если получилось отрицательное значение, увеличим его на 7.
Проверим ,будет ли это работать.
1 января - Сб (номер дня 6) алгоритм дает 1-2 = -1 и +7 = 6 - верно
2 января - Вс (номер дня 0) алгоритм дает 2-2 = 0 - верно
3 января - Пн (номер дня 1) алгоритм дает 3-2 = 1 - верно
4 января - Вт (номер дня 2) алгоритм дает 4-2 = 2 - верно
5 января - Ср (номер дня 3) алгоритм дает 5-2 - 3 - верно
6 января - Чт (номер дня 4) алгоритм дает 6-2 = 4 - верно
7 января - Пт (номер дня 5) алгоритм дает 0-2 = -2 и +7 = 5 - верно
8 января - Сб (номер дня 6) алгоритм дает 1-2 = -1 и +7 = 6 - верно
9 января - Вс (номер дня 0) алгоритм дает 2-2 = 0 - верно

Все работает.

// PascalABC.NET 3.3, сборка 1625 от 17.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var chislo:=ReadInteger('Номер дня в январе 2011 года:');
  chislo:=chislo mod 7-2;
  if chislo<0 then chislo:=chislo+7;
  var y:string;
  case chislo of
  0:y:='Воскресенье';
  1:y:='Понедельник';
  2:y:='Вторник';
  3:y:='Среда';
  4:y:='Четверг';
  5:y:='Пятница';
  6:y:='Суббота'
  end;
  Writeln('Это ',y)
end.

Примеры
Номер дня в январе 2011 года: 31
Это Понедельник

Номер дня в январе 2011 года: 13
Это Четверг

Номер дня в январе 2011 года: 23
Это Воскресенье

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Укого с информатикой хорошо? 9 класс написать программу для нахождения минимального элемента массива а(21 написать программу, находящую номер первого и последнего отрицательного элементов массива y(25). вычислить среднее арифметическое положительных четных элементов массива а(n).
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

director3
Bordo
Seid-ZadeNadezhda1769
pokupatel688
boykovandrew6663
knyazev527
Палкина-Дроздова
Волков1968
vbnm100584
Ivanovich-A.V
ekaterinaorl1998
taksa6444
qwqwweqw3
Melsan19914239
artem032100