Dom540703174
?>

30 ! , заранее ) от этой зависит моя оценка за четверть, поэтому как можно быстрее написать решение, вот сама : составьте программу на языке паскаль. имеется массив на 20 чисел, его необходимо заполнить и найти сумму чисел, которые больше 30. свое решение есть, но я вообще не шарю в информатике.

Информатика

Ответы

kuznecovav3066

const n=20;

var a:array [1..n] of integer;

i,s:integer;

begin

write('Массив: ');

for i:=1 to n do

begin

a[i]:=random(31)+20;

write(a[i]:3,' ');

if a[i] > 30 then s:=s+a[i]

end;

writeln;

write('Сумма чисел, больше 30: ',s)

end.

yuda12

import turtle

from math import tan, sqrt, pi

def prepare(x, y, color):

   turtle.penup()

   turtle.goto(x, y)

   turtle.pendown()

   turtle.color(color)

   turtle.begin_fill()

def draw_polygon(num_sides, side_length):

   angle = 360.0 / num_sides

   for i in range(num_sides):

       turtle.forward(side_length)

       turtle.right(angle)

   turtle.end_fill()

def calc_s(num_sides, side_length):

   return num_sides * side_length ** 2 / (4 * tan(pi/num_sides))

def calc_side(square):

   return sqrt(4 * square * tan(pi/num_sides) / num_sides)

turtle.hideturtle()

turtle.speed(10)

colors = ['red', 'green', 'blue', 'cyan', 'magenta', 'black', 'yellow', 'pink', 'brown']

xcoords = [0, 150, -150, 150, -150, 270, -270, 270, -270]

ycoords = [0, 150, -150, -150, 150, 270, -270, -270, 270]

squares = []

numsides = []

for i in range(9):

   num_sides = i + 3

   square = round(calc_s(num_sides, 100), 2)

   side_length = round(calc_side(10000), 3)

   squares.append(square)

   numsides.append(num_sides)

   print("Углов:", num_sides, "была площадь:", square, "стала длина грани:", side_length,

         "изменение в", round(side_length/100, 2), "раз")

   prepare(xcoords[i], ycoords[i], colors[i])

   draw_polygon(num_sides, side_length)

turtle.exitonclick()

print("Список количество углов:", numsides, end="")

print("Список площади:", squares)

Объяснение:

stailwomen31

Введение

Построение и использование компьютерных моделей

Пути построения компьютерных моделей

Список литературы

Введение

Компьютерное моделирование начинается как обычно с объекта изучения, в качестве которого могут выступать: явления, процесс, предметная область, жизненные ситуации, задачи. После определения объекта изучения строится модель. При построении модели выделяют основные, доминирующие факторы, отбрасывая второстепенные. Выделенные факторы перекладывают на понятный машине язык. Строят алгоритм, программу.

Когда программа готова, проводят компьютерный эксперимент и анализ полученных результатов моделирования при вариации модельных параметров. И уже в зависимости от этих выводов делают нужные коррекции на одном из этапов моделирования: либо уточняют модель, либо алгоритм, либо точнее, более корректнее определяют объект изучения.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

30 ! , заранее ) от этой зависит моя оценка за четверть, поэтому как можно быстрее написать решение, вот сама : составьте программу на языке паскаль. имеется массив на 20 чисел, его необходимо заполнить и найти сумму чисел, которые больше 30. свое решение есть, но я вообще не шарю в информатике.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

julkamysh9
mrFuz
premiumoft
buleckovd8724
irkm8
Виталий887
Anatolevich
Dmitrii836
sargisyan77
veravlad
Низамов
veronica1344
paninsv
lovely138887
ПетросовичЗаславский
Назначение всех клавиш клавиатуры (, )