natakrechko
?>

Задано четырехзначное натуральное число х. составить программу с++ для получения из него числа, записанного теми же цифрами, но в обратном порядке, а так же сумму исходного и полученного числа.

Информатика

Ответы

romolga3580

#include <iostream>

using namespace std;

int rec(int a, int &b)

{

   if(a/10==0)

   {        

       return a%10;

   }    

   int t=rec(a/10, b);

   b*=10;

   return t+(a%10) *b;

 

}

int main(){

   int a, b=1;

   cin>>a;

   int f = rec(a,b);

   cout<<f<<endl;  

   cout<< f + a;

 

return 0;

}

Svetlana1877
Самый простой это с операций целочисленного деления разбить общее число секунд на часы, минуты, секунды. Далее собрать нужную строку из получившихся значений, преобразовывая в строки. Учитывая длины получившихся подстрок где надо добавляем 0 слева от начала подстроки.

n = int(input('Число секунд с начала суток: '))
h = n // 3600
n = n % 3600
m = n // 60
s = n % 60
sh = str(h)
sm = str(m)
if len(sm)<2:
    sm = "0"+sm
ss = str(s)
if len(ss)<2:
    ss = "0"+ss
print(sh,':',sm,':',ss)

Тест №1
Число секунд с начала суток: 7200
2 : 00 : 00

Тест №2
Число секунд с начала суток: 75201
20 : 53 : 21
baranova302

#include <iostream>

int main() {

//#1

 int first, last;

 std::cout << "#1\n";

 std::cout << "Input first integer: ";

 std::cin >> first;

 std::cout << "Input last integer: ";

 std::cin >> last;

 for (int i = first; i <= last; ++i)

   std::cout << i << " ";

 std::cout << std::endl;

//#2

 int num1, num2;

 std::cout << "\n#2\n";

 std::cout << "Input first integer: ";

 std::cin >> num1;

 std::cout << "Input second integer: ";

 std::cin >> num2;

 for (int i = 1; i <= 1000; ++i) {

   if (i % num1 == 0 && i % num2 == 0)

     continue;

   std::cout << i << " ";

 }

 std::cout << std::endl;

//#3

 std::cout << "\n#3\n";

 for (int i = 100, j = 1; j <= 50; --i, ++j) {

   std::cout << i << " " << j << " ";

 }

 return 0;

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Задано четырехзначное натуральное число х. составить программу с++ для получения из него числа, записанного теми же цифрами, но в обратном порядке, а так же сумму исходного и полученного числа.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

vifslafes
yuda12
Полковников_Милана
fedoseevalyubov
Amelin-Alipova
Elenazhukovafashion7
bandurinei
kononova_Pavel689
akopsiroyan
Matveevanastya0170
Александр1991
Bella Sergei
Vitalevich
peregovorkacoffee
arteevdimon
▲