Program mas; uses crt; var X:array [1..8,1..7] of integer; i,j,a,b:integer; begin clrscr; write('Введите диапазон значений заполнения(A-начальное значение, B-конечное): '); repeat read(a,b); until a<=b; writeln; randomize; for i:=1 to 8 do for j:=1 to 7 do X[i,j]:=random(b-a+1)+a; writeln('Ваш массив:'); for i:=1 to 8 do begin for j:=1 to 7 do write(X[i,j]:5); writeln; end; for i:=1 to 8 do for j:=1 to 3 do X[i,j]:=sqr(X[i,j]); writeln; writeln('Рeзультат:'); for i:=1 to 8 do begin for j:=1 to 7 do write(X[i,j]:5); writeln; end; readkey; end.
arinaunknown6867
13.09.2021
Задача с регионального этапа года) На паскале решение выглядит так: var s,a1,a2,a3,a4:int64; i,o:text;
function min(x,y:int64):int64; begin if x>y then min:=y else min:=x; end;
Если ты пишешь на другом языке программирования, то могу коротко рассказать суть решения. Большой квадрат со стороной x получается из x^2 маленьких квадратом, которые состоят из двух прямоугольных треугольников. Такие квадраты можно составить из треугольников a1 и a2 или a3 и a4. Поэтому берём минимальное значение из a1 и a2 и минимальное из a3 и a4. Суммируем эти значения, берём корень и округляем в меньшую степень.
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
напишите программу на языке паскаль для решения уравнения: ax+b/a=cесли x> 20, то ввести на экран фразу "x> 20", иначе ввести "x≤20".
uses crt;
var X:array [1..8,1..7] of integer; i,j,a,b:integer;
begin
clrscr;
write('Введите диапазон значений заполнения(A-начальное значение, B-конечное): ');
repeat
read(a,b);
until a<=b;
writeln;
randomize;
for i:=1 to 8 do
for j:=1 to 7 do X[i,j]:=random(b-a+1)+a;
writeln('Ваш массив:');
for i:=1 to 8 do
begin
for j:=1 to 7 do write(X[i,j]:5);
writeln;
end;
for i:=1 to 8 do
for j:=1 to 3 do X[i,j]:=sqr(X[i,j]);
writeln;
writeln('Рeзультат:');
for i:=1 to 8 do begin for j:=1 to 7 do write(X[i,j]:5);
writeln;
end;
readkey;
end.