nataliarogacheva
?>

Составить модель, блок-схему и написать программу на языке программирования паскаль. собственная скорость катера равна х км/ч, а его скорость против течения реки у км/ч. с какой скоростью течет река? какова скорость катера по течению реки?

Информатика

Ответы

anastasiavilina

использовать Рисователь

алг

нач

новый лист(600, 400, белый)

в точку (250,350)

линия в точку (300,75)

линия в точку (350,350)

линия в точку (250,350)

кисть(красный)

окружность(300, 75, 20)

залить(300,250)

в точку (200,350)

линия в точку (100,100)

линия в точку (265,265)

линия в точку (250,350)

линия в точку (200,350)

кисть(синий)

окружность(100, 100, 20)

залить(200,300)

в точку (400,350)

линия в точку (500,100)

линия в точку (335,265)

линия в точку (350,350)

линия в точку (400,350)

кисть(зеленый)

окружность(500, 100, 20)

залить(400,300)

кон

Объяснение:

Смотри картинку


Сделайте вот такую корону в кумире
kyrtlab39
//Обьявляем дополнительные переменные и главный массив, а также два дополнительных - они будут "половинками".
var
  a, b, c: array [1..100] of longint;
  i, min, n, j, t: longint;

begin
  //Читаем количество элементов в нашем массиве.
  readln(n);
 
  //Читаем массив.
  for i := 1 to n do read(a[i]);
 
  //Заполняем первую "половинку".
  for i := 1 to n div 2 do b[i] := a[i];
 
  //Заполняем вторую "половинку". Но раз это уже вторая "половинка" главного массива, то и
  //цикл теперь должен начинаться со второй части массива, а заканчиваться уже в его конце.
  for i := n div 2 + 1 to n do c[i - n div 2] := a[i];
 
  //Теперь отсортируем первую "половинку" методом выбора. Идея этого метода
  //основывается на том, что мы ищем минимальный среди неотсортированных элемент,
  //а затем просто swap-аем его с тем, который стоит сразу после отсортированных.
  for i := 1 to (n - 1) div 2 do
  begin
    min := i;
    for j := i + 1 to n div 2 do
      if b[min] > b[j] then
        min := j;
    if min <> i then begin
      t := b[i];
      b[i] := b[min];
      b[min] := t;
    end;
  end;
 
  //Затем вторую точно также, только стоит обратить внимание на сравнения.
  //Так как надо отсортировать по убыванию, то теперь сравнение перед "swap"-ом
  //будет другим.
  for i := 1 to (n - 1) div 2 do
  begin
    min := i;
    for j := i + 1 to n div 2 do
      if c[min] < c[j] then
        min := j;
    if min <> i then begin
      t := c[i];
      c[i] := c[min];
      c[min] := t;
    end;
  end;
 
  //А теперь просто по очереди выводим готовые "половинки", не забывая ставить
  //пробел после вывода каждого элемента.
  for i := 1 to n div 2 do write(b[i], ' ');
  for i := 1 to n - n div 2 do write(c[i], ' ');
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить модель, блок-схему и написать программу на языке программирования паскаль. собственная скорость катера равна х км/ч, а его скорость против течения реки у км/ч. с какой скоростью течет река? какова скорость катера по течению реки?
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

gav973
АлександрАнатолий
teya07
multikbo3049
maksimovskiy7657
Vyacheslavovna1867
toniv
anton
azarov8906
Tomilova1686
bruise6
mtcover
Vip2002www86
srvsm
Antonov-Elena