родичева1812
?>

Создать рекурсивную функцию, которая находит цифровой корень числа. pascal

Информатика

Ответы

alisapavlushina

function kor(n:integer):integer;

var s:integer;

begin

if n>9 then

begin

s:=0;

while n>0 do

 begin

 s:=s+n mod 10;

 n:=n div 10;

 end;

 kor:=kor(s);

 end

else kor:=n;

end;

begin

writeln(kor(87345691));

writeln(87345691 mod 9);

end.

Результат:

7

7

cheshirsky-kot
1. Изучала ли ты информатику в школе?
Да , мы изучали информатику в школе!
2. Как звали учителя по этому предмету?
Её звали Анна Григорьевна.
3. Какой был номер кабинета?
Номер кабинета иформатики - 21
4. Что больше всего запомнилось из уроков?
Разные опыты секреты и хитрости с компьютерами!
5. Что пригодилось в жизни из этих знаний?
Да сейчас у меня очень много техники, если бы я не изучал бы информатику в школе то я бы не мог пользоваться техникой.
6. Для каких целей ты используешь компьютер?
Програмирование.
Alsergus7811
ЕСЛИ БУДЕТ НЕ ПРАВИЛЬНО НЕ БАНЬТЕ Я НЕ 8 класс

Задача
Требуется написать программу, вычисляющую значение какой-либо функции у = f(x). Допустим, такой:

у = x – 2, если x > 0,
y = 0, если x = 0,
y = |x|, если x < 0.
Решение
При определении значений подобных функций переменная y вычисляется по-разному (по разным формулам) в зависимости от значения x.

Такие задачи решаются с конструкции условного оператора if - else. Поскольку в данном случае мы имеем три условия (x > 0, x = 0 и x < 0), то потребуется использование еще вложенной конструкции if - else, т. к. в языке Pascal нет оператора множественного ветвления (оператор case в данном случае не подходит).

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Создать рекурсивную функцию, которая находит цифровой корень числа. pascal
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

olegmgu1
Varagyan1728
rusdtver
Anna572
Rudakova_Yana
Mexx9050
zbellatriks
obelov
xarchopuri22
dream2366
mon84
nikitavertiev98400
kogakinoa
sakalrip
kabinet17
▲