yuliasam
?>

Напишите программу, которая анализирует человека по возрасту и относит к одной из четырех групп: дошкольник, ученик, работник, пенсионер. возраст человека вводится с клавиатуры

Информатика

Ответы

KrisTinka

то что подчеркнуто на минимальный возвраст группы заменить.

? "введите возвраст человека"

input a

if a> пенсионер then 1 else 2

1 ? "группа пенсионеров" : goto 10

2 if a> работник then 3 else 4

3 ? "группа работников" : goto 10

4 if a> ученик then 5 else 6

5 ? "группа учеников" : goto 10

6 ? "группа дошкольников"

10 end

Yelena_Yuliya1847
Pascal: var a: array [1..30] of integer;             i: integer;           p: longint; begin   p: =1;   randomize;     a[1]: =random(21)+50;   for i: =2 to 29 do a[i]: =random(100);   a[30]: =random(21)+50;   for i: =1 to  30 do write (a[i],' ');   writeln;   for i: =1 to  30 do       if (a[i] in [10..99]) and (a[i] mod 2 = 0) and ((a[i] div 10)  in [5..7]) then  p: =p*a[i];   writeln ('proizvedenie: ',p);   readln; end. c++: #include < iostream> #include < ctime> #include < cstdlib> using namespace std; int main() {   int a[30],i;   unsigned long long p = 1;   srand (time(null));   a[0] = rand()%70+50;   for (i =  1; i< 29; i++)       a[i] = rand()%100;   a[29] = rand()%7+50;   for (i = 0; i< 30; i++)   {         cout < < a[i] < < " ";         if ((a[i]/10==5 || a[i]/10==6 || a[i]/10==7)  & & (a[i]> 9 & & a[i]< 100) & & a[i]%2==0)           p*=a[i];     }   cout < < endl;   cout < < "proizvedenie: " < < p < < endl;   return 0; }
gordeevadesign2986
Pascal: var a: array [1..5] of integer;           i: integer; begin   randomize;   for i: =1 to 5 do        begin             a[i]: =random(31)-15;           write (a[i]: 4);         end;   writeln;   for i: =1 to 5 do       begin           a[i]: =a[i]*2;             write (a[i]: 4);       end;   writeln;   readln; end. c++: #include < iostream> #include < ctime> #include < cstdlib> using namespace std; int main() {     int a[5];     srand (time(null));     for  (int  i = 0; i< 5; i++)     {           a[i] = rand()%15-15;             cout < < a[i] < < " ";       }     cout < < endl;     for (int  i = 0; i< 5;   i++)     {             a[i]*=2;           cout < < a[i] < < " ";       }     return 0; }

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая анализирует человека по возрасту и относит к одной из четырех групп: дошкольник, ученик, работник, пенсионер. возраст человека вводится с клавиатуры
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Lesya
teashop
des-32463
temik10808564
baton197310
olgavbaranova
Vlad Petr531
впвыпвып-Зуйков629
daarisgoy
ev89036973460
Ильдар-Кугай
gallows-warlike-0z
Chutaeva381
MikhailovnaAnastasiya
universal21vek116
▲