vladislavk-market2
?>

Написать программу на c++ цикл со счетчиком с клавиатуры вводится n целых чисел a1, a2, …, an. в процессе ввода чисел выводить на экран следующие суммы: a1+a2, a2+a3, …, an-1+an. цикл с предусловием вычислите сумму всех чисел фибоначчи, которые не превосходят заданного натурального числа м. числа фибоначчи определяются по формулам: f0=f1=1; fi=fi-1+fi-2. цикл с постусловием вычислите частичную сумму ряда s=1 -x^2/2! + x^4/4! - x^6/6! + … . вычисления прекратите, когда модуль очередного слагаемого станет меньше 0, 001. значение x вводится с клавиатуры. проверьте, насколько сумма приблизилась к значению cos(x), x измеряется в радианах.

Информатика

Ответы

Максим Павел

ответы программы (наименьшее значение из трёх):

1) 0.0828638516274247

2) 0.164832693219929

3) 0.145644125326545

Два текста программы (отличия во вводе икс и нахождения наименьшего):

var

x,a,b,c: real;

begin

write('x= ');

read(x);

a:=Exp(Power(Sin(x),2));

b:=1+Exp(Abs(x))/(1+Ln(Abs(Power(x,1/3;

c:=Tan(x/2)/(2+0.8*Power(x,4));

writeln('a= ',a);

writeln('b= ',b);

writeln('c= ',c);

write('min= ');

if a<b then

if a<c then write(a) else write(c)

else

if b<c then write(b) else write(c);

end.

var x,a,b,c: real;

begin

x:=ReadReal('x=');

a:=Exp(Power(Sin(x),2));

b:=1+Exp(Abs(x))/(1+Ln(Abs(Power(x,1/3;

c:=Tan(x/2)/(2+0.8*Power(x,4));

writeln('a= ',a);

writeln('b= ',b);

writeln('c= ',c);

write('min= ',Min(Min(a,b),c));

end.

Pochkun-Oleg

#define _USE_MATH_DEFINES

#include <iostream>

#include <math.h>

int main()

{

   setlocale(LC_ALL, "rus");

   double x, y, z, result;

   std::cout << "Введите x,y,z: \n";

   std::cin >> x >> y >> z;

   result = tan(x + y) - pow(M_E, y - z) * sqrt(cos(pow(x, 2)) + sin(pow(z, 2)));

   std::cout << "Результат: " << result;

}

Этот код не проверяет корректность введённых данных.

То есть если x+y будет равен π/2 или выражение под корнем будет отрицательным, будет ошибка приложения

Такой вариант с обработкой исключений

#define _USE_MATH_DEFINES

#include <iostream>

#include <math.h>

int main()

{

   setlocale(LC_ALL, "rus");

   double x, y, z, result, result2;

   std::cout << "Введите x,y,z: \n";

   std::cin >> x >> y >> z;

   try  

   {

       result2 = cos(pow(x, 2)) + sin(pow(z, 2));

       if (result2 < 0) throw "подкоренное выражение меньше нуля";

       if ((x + y) == M_PI_2) throw "тангенс не определён";

       result = tan(x + y) * pow(M_E, y - z) * sqrt(result2);

       std::cout << "Результат: " << result;

     

   }

   catch(const char* exception)

   {

       std::cout << "Результат не может быть вычислен поскольку " << exception;

   }

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на c++ цикл со счетчиком с клавиатуры вводится n целых чисел a1, a2, …, an. в процессе ввода чисел выводить на экран следующие суммы: a1+a2, a2+a3, …, an-1+an. цикл с предусловием вычислите сумму всех чисел фибоначчи, которые не превосходят заданного натурального числа м. числа фибоначчи определяются по формулам: f0=f1=1; fi=fi-1+fi-2. цикл с постусловием вычислите частичную сумму ряда s=1 -x^2/2! + x^4/4! - x^6/6! + … . вычисления прекратите, когда модуль очередного слагаемого станет меньше 0, 001. значение x вводится с клавиатуры. проверьте, насколько сумма приблизилась к значению cos(x), x измеряется в радианах.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Диана-Николаевна377
jnrhjq3597
Сергеевич
stalker2201
sv455umarketing74
Сергеевна
webotryvclub21
boykoz9
Kushchenko-Monashev
armusaeff
dimiff5
Surkova_Pavlovna
РоманТрофимов2012
Allahverdi_Мария475
lazu8375
▲