Равилевич_Олеговна1496
?>

Вредакции театра авторам платят по количеству цифр в нумерации страниц сценариев. автор пьесы получил гонорар за 1392 цифры. сколько страниц в этой пьесе? составьте программу, определяющую число цифр в указанном количестве страниц и, обратно, число страниц при известном количестве цифр. в последнем случае организовать сообщение, что исходная информация ложна, если указанное количество цифр не соответствует никакому количеству страниц. c++, )

Информатика

Ответы

nikolotovas
1) Б и С
2) read(a) ввод в переменную с клавиатуры. a:=значение просто присваивание 
3) 

program a1; 
var a, b, c: integer; 
begin 
writeln('введите значения переменных a и b'); 
read(a, b); 
writeln((a+b+c)/3); 
end. 

Название программы и переменной были одинаковые. Так нельзя. Переименовал программу

4) б)

program znanija; 
var a, b, h: integer; 
begin 
writeln('Введите a, b и h'); 
read(a, b, h); 
writeln('Площадь трапеции ',(a+b)/2*h); 
end. 

5)

program znanija; 
var a, b, i: integer; 
begin 

read(a);

for i:=1 to a do 
begin   
b:=b + a mod 10;   
a:=a div 10; 
end;  

writeln(b);
end. 

Работает не только для трёхзначных. Но и двух, трёх, четырёх и т.д.
hvostna23
1)
a) не может, потому что переменные должны всегда начинаться с буквы
b) может
c) не может, слова могут быть разделены только знаком "_",не пробелом!
d) может

2) присваивание, обозначается знаком "="
Например:
sum = 0;

3) 
4 строка - не red, а read
пропущена трока между 2 и 3 строчкой - это begin

4)
var
     S, P, a, b: integer
begin
     write('Введите сторону а: ');
     readln(a);
     write('Введите сторону b: ');
     readln(b);
     
     S = a * b; {нахидим площадь}
     P = (a + b) * 2; {находим периметр}

     writeln('Площадь = ', S, ', периметр = ', P);
end.

5)
Var
     number, {Трехзначное число}
     num1, {Первая крайняя цифра}
     num2, {Вотрая крайняя цифра}
     : integer;
Begin
     write('Введите число');
    readln(number);
   
     num1 = number mod 10;
     num2 = number div 100;
    
     writeln('Сумма крайних цифр числа ', number, ' = ', num1 + num2);
End.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Вредакции театра авторам платят по количеству цифр в нумерации страниц сценариев. автор пьесы получил гонорар за 1392 цифры. сколько страниц в этой пьесе? составьте программу, определяющую число цифр в указанном количестве страниц и, обратно, число страниц при известном количестве цифр. в последнем случае организовать сообщение, что исходная информация ложна, если указанное количество цифр не соответствует никакому количеству страниц. c++, )
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

vickuznetsova8677
Lusiarko65
msk27
ksoboleva
syana80
Pastushenkoen
Talikova164
a-lossev111
dimoni86
farmprofi
Natalya1070
Mariya987
blackpoint2020273
Yurevich1344
boykovandrew6663
▲