Grigorev_Nikita794
?>

Составьте алгоритм вычисления суммы всех натуральных чисел, не превышающих заданного натурального числа n. напишите программу на паскале.

Информатика

Ответы

kabinet17

var sum,n,i: integer;

begin

readln(n);

sum: =0;

for i: =1 to n do

    sum: =sum+i;

writeln(sum);

readln;

end.

annazhurawlewa
1) program task1; var x,y,xq,yq,sum,pro,cha,raz: integer; begin write('введите числа: '); readln(x,y); xq: =sqr(x); yq: =sqr(y); sum: =xq+yq; raz: =xq-yq; pro: =xq*yq; cha: =xq/yq; write('сумма=',sum,'; разность=',raz,'; частное=',cha,'; произведение=',pro); end. 2) program task2; var a,r,rr,h,s: real; begin   write('введите длину стороны треугольника: ');   readln(a);   r : = sqrt(3) * a / 6;   rr : = 2 * r;   h : = 3 * r;   s : = a * h / 2;   writeln('радиус вписанной окружности ', r: : 2);   writeln('радиус описанной окружности ', rr: : 2);   writeln('высота треугольника ', h: : 2);   writeln('площадь треугольника ', s: : 2); end.
mado191065
Представим слова, как числа в 3сс, (где а=0, о=1, у=2.) тогда:   00000   1место   00001   2место     на 101 (10сс)  месте будет стоять число 100 (10сс) 100 (10сс) =10201 (3сс) = оауао на 125 (10сс) месте 124(10сс) =11 121 (3сс) = на 170(10сс) месте   169(10сс) = 20021 (3сс) = уаауо на 210 месте     209 (10сс) =21202 (3сс) = уоуау первое число, которое начинается с "о" ==10000 (3сс) =   =81 (10сс),   номер  его места = 82 (10сс) последнее, которое начинается на "о"   ==12222 (3сс) = =161 (10сс), номер его места = 162(10сс)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте алгоритм вычисления суммы всех натуральных чисел, не превышающих заданного натурального числа n. напишите программу на паскале.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

bochkarevazh
tyrenumberone
appbiznessm
Михайлович1309
Bologova Golovach1989
aamer9992680
Ivan1568
Khiryanov
melissa-80
mnkrasnova
Виталий_Ильназ574
Milovidova
tatur-642789
mstapottery
Вишняков997
▲