natalyaionova
?>

Напишите программу паскале, которая выбирает из списка футболистов, год рождения которых находится в диапазоне от k до m , и которые забили за сезон ровно b мячей. входные данные в первой строке вводятся три числа: k , m и b . во второй строке записано количество футболистов в списке n . следующие n строк имеют формат: < фамилия> < имя> < год рождения> < число забитых мячей> выходные данные программа должна вывести фамилии и имена тех футболистов, год рождения которых находится в диапазоне от k до m , и которые забили за сезон ровно b мячей. в последней строке программа выводит количество футболистов в итоговом списке.

Информатика

Ответы

matterfixed343
Алфавит- символы для записи конструкций языка программирования (из каких знаков составляются конструкции языка). Алфавит языка состоит из букв, цифр и лексем.
Лексема - это наименьшая единица языка имеющая самостоятельный смысл. К лексемам относятся:
спецсимволы (==, !=, ++, =, >, < и т.д.);
ключевые слова (main, switch, if, while и т.д.).
Синтаксис
Правила записи конструкций языка (какие конструкции принадлежат языку).
Семантика
Смысл конструкций языка программирования (как конструкции обрабатываются компьютером).
spz03

1.

program z1;

var i,n,S: integer;

begin

write ('n = ');

read (n);

S:=0;

write ('S = ');

for i:=1 to n do

begin

write (i*2-1,'^2');

if i<n then write (' + ') else write (' = ');

S:=S + sqr(i*2-1)

end;

write (S)

end.

2.

program z2;

var i,n,S: integer;

begin

write ('n = ');

read (n);

S:=0;

i:=1;

write ('S = ');

repeat

write (i*2-1,'^2');

if i<n then write (' + ') else write (' = ');

S:=S + sqr(i*2-1);

i:=i+1

until i>n;

write (S)

end.

3.

program z3;

var i,n,S: integer;

begin

write ('n = ');

read (n);

S:=0;

i:=1;

write ('S = ');

while i<=n do

begin

write (i*2-1,'^2');

if i<n then write (' + ') else write (' = ');

S:=S + sqr(i*2-1);

i:=i+1  

end;

write (S)

end.

Объяснение:

картинки


Нужно в Паскале написать с 1 циклом For 2 циклом Repeat 3 циклом While и дожно быть 3 команды с кажд
Нужно в Паскале написать с 1 циклом For 2 циклом Repeat 3 циклом While и дожно быть 3 команды с кажд
Нужно в Паскале написать с 1 циклом For 2 циклом Repeat 3 циклом While и дожно быть 3 команды с кажд

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу паскале, которая выбирает из списка футболистов, год рождения которых находится в диапазоне от k до m , и которые забили за сезон ровно b мячей. входные данные в первой строке вводятся три числа: k , m и b . во второй строке записано количество футболистов в списке n . следующие n строк имеют формат: < фамилия> < имя> < год рождения> < число забитых мячей> выходные данные программа должна вывести фамилии и имена тех футболистов, год рождения которых находится в диапазоне от k до m , и которые забили за сезон ровно b мячей. в последней строке программа выводит количество футболистов в итоговом списке.
Ваше имя (никнейм)*
Email*
Комментарий*