Кочугурова
?>

Много ! 1! , , написать программу на паскале: ввести два целых числа a и b (a ≤ b) и вывести сумму квадратов всех чисел от a до b.

Информатика

Ответы

Александра Викторович531

####################


Много ! 1! , , написать программу на паскале: ввести два целых числа a и b (a ≤ b) и вывести сумму к
santechma
Const n=20;
type omas=array[1..n] of integer;
Procedure Del (var z:omas; k:byte); 
var i:byte; 
begin 
for i:=k to n-1 do z[i]:=z[i+1]; 
z[n]:=0; 
end; 
var a:omas; i,b:integer;
begin
Randomize;
for i:=1 to n do
 begin
 a[i]:=random(20);
 write(a[i]:4);
 end;
writeln;
b:=6;
i:=1;
while (i<=n)and(a[i]<>b) do i:=i+1;
if i<=n then
  begin
  Del(a,i);
 writeln('Размерность массива = ',n-1);
 for i:=1 to n-1 do write(a[i]:4);
 writeln;
 end  else writeln('Массив не изменился');
end.
Пример:
  12  13   6   7  17   1  18  17   3   2  12   3  16   6   7  13   0   2   5  18
Размерность массива = 19
  12  13   7  17   1  18  17   3   2  12   3  16   6   7  13   0   2   5  18
tshelokova
N1
var a, b: integer;

•​ begin

•​ readln(a, b);

•​ a := a mod 2;
b := b mod 2;
•​ if (b > 0) and (a > 0) then

•​ writeln ('четных чисел нет')

•​ else

•​ writeln ('четное число есть');
end.

N2

#include <iostream>

using namespace std;

int main()
{
  int a;
  cin >> a;
  if(a < 100 || a > 999) cout  << "Неверное число" << endl;
  else
  {
    int a1 = a/100;
    int a2 = (a/10)%10;
    int a3 = a%10;
    if(a1%2==a2%2==a3%2==0) cout << "Да" << endl;
    else cout << "Нет" << endl;
  }
  return 0;
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Много ! 1! , , написать программу на паскале: ввести два целых числа a и b (a ≤ b) и вывести сумму квадратов всех чисел от a до b.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

natakrechko
Yulechkaakulova1993
Николаевич
Rakitin
Tatyanaaarzieva72
rendikalogistic
tvshi
vintazhvintazh90
Константиновна
Albina
Zaikinarusina
jamaltreid
Tsevich333639
Татьяна1252
MAXIM76748