Половников1964
?>

Даны два действительных числа а и б. получить их сумму, разность и произведение. написать программу так, чтобы результат выводился полным ответом (например, 4*5=20, если были введены числа 4 и 5 (паскаль). , , .

Информатика

Ответы

Vyacheslavovich Mikhailovich1421

var a, b, sum, subt, multi: real;

begin

   readln(a, b);

   sum:= a + b;

   writeln(a, '+', b, '=', sum);

   subt:= a - b;

   writeln(a, '-', b, '=', subt);

   mult:= a * b;

   writeln(a, '*', b, '=', mult);

end.

N-odes-art-school410
Массив сначала заполнится так:
a[0]=0
a[1]=1
...
a[10]=10
0 1 2 3 4 5 6 7 8 9 10
во втором цикле:
в первом проходе:
0 1 2 3 4 5 6 7 8 9 0
последний элемент замениться на 1 элемент
во 2 проходе:
предпоследний элемент заменится на 2 элемент
0 1 2 3 4 5 6 7 8 1 0
и так дальше:
3)0 1 2 3 4 5 6 7 2 1 0 
4)0 1 2 3 4 5 6 3 2 1 0 
5)0 1 2 3 4 5 4 3 2 1 0 
6)0 1 2 3 4 5 4 3 2 1 0 
дальше массив изменятся не будет:
7)0 1 2 3 4 5 4 3 2 1 0 
8)0 1 2 3 4 5 4 3 2 1 0 
9)0 1 2 3 4 5 4 3 2 1 0 
10)0 1 2 3 4 5 4 3 2 1 0 
11)0 1 2 3 4 5 4 3 2 1 0 - полученный массив
ответ: 4
Александрович833

a = float(input(' 1-го судьи: '))

b = float(input(' 2-го судьи: '))

c = float(input(' 3-го судьи: '))

d = float(input(' 4-го судьи: '))

e = float(input(' 5-го судьи: '))

f = float(input(' 6-го судьи: '))

g = float(input(' 7-го судьи: '))

h = float(input(' 8-го судьи: '))

i = float(input(' 9-го судьи: '))

j = float(input(' 10-го судьи: '))

all_balls = []

all_balls.append(a)

all_balls.append(b)

all_balls.append(c)

all_balls.append(d)

all_balls.append(e)

all_balls.append(f)

all_balls.append(g)

all_balls.append(h)

all_balls.append(i)

all_balls.append(j)

max_ball = max(all_balls)

min_ball = min(all_balls)

ball_sred = (max_ball + min_ball) / 2

print(f'Ваша оценка: {ball_sred}')

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Даны два действительных числа а и б. получить их сумму, разность и произведение. написать программу так, чтобы результат выводился полным ответом (например, 4*5=20, если были введены числа 4 и 5 (паскаль). , , .
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

mikhisakov2017
apromovich1
yelenaSmiryagin
chapaevval
albina6580
Igorevich_Aleksandrovna1599
Кирилл-Морозова
Хелп непон смысл задания даже ​
zorinka777
Екатерина_Кирушев
Vika-simonenko
info8
ambstroy
shugayzhanna6
Кристина910
vladimir152