rudakovam198
?>

Запишите название программы которая имеет единственный результат записываем в ячейку памяти

Информатика

Ответы

zmlavra

Так как язык не указан, приведу пример на SWI-Prolog.

Код:

read_int(Int) :- read(Int), integer(Int).split_int_by_numbers(0, []) :- !.split_int_by_numbers(N, [Number|Ints]) :- Number is mod(N, 10), RestN is div(N, 10), split_int_by_numbers(RestN, Ints).test_to_div(_, []).test_to_div(N, [Number|Ints]) :- mod(N, Number) =:= 0, test_to_div(N, Ints). test(Int) :- split_int_by_numbers(Int, Numbers), test_to_div(Int, Numbers), write(Int), write(" - Yes!"), nl.test(Int) :- write(Int), write(" - No!"), nl.?- read_int(Int), test(Int).
Напишите программу: С клавиатуры вводится трёхзначное число (число десятков и число единиц не равна
Напишите программу: С клавиатуры вводится трёхзначное число (число десятков и число единиц не равна
Напишите программу: С клавиатуры вводится трёхзначное число (число десятков и число единиц не равна
annademidova-74
Var a:array[1..100,1..100] of integer; i,j,n,m,max,min:integer; begin write ('Введите количество строк: '); read(n); writeln; write ('Введите количество элементов в строке: '); read(m); writeln; writeln('Введите массив: '); for i:=1 to n do begin for j:=1 to m do begin write(' a[',i,',',j,']='); read(a[i,j]); end; writeln; end; writeln; writeln('Исходный массив: '); for i:=1 to n do begin for j:=1 to m do write(a[i,j],' '); writeln; end; writeln; writeln('Конечный массив: '); for i:=1 to n do begin min:=a[i,1]; max:=a[i,1]; for j:=2 to m do begin if (min>a[i,j]) then min:=a[i,j]; if (max

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Запишите название программы которая имеет единственный результат записываем в ячейку памяти
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

shyroshka836103
vodexshop2
Николаевич
sychevao19975
Tatyanaaarzieva72
rendikalogistic
Татьяна-Мишин1307
alekseymedvedev1981
Surkova_Pavlovna
anastasiaevent4
maximovpavel9114
tatianamatsimoh
Batishcheva
praskovya17
akarabut343