magichands68
?>

Напишите программу, которая в последовательности целых чисел определяешь сумму чисел, а также количество чисел, кратных 5 или 9. программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается 0 (0-признак окончания ввода, не входит в последовательность количество чисел не превышает 1000. введённые числа по модулю не превышают 30 000

Информатика

Ответы

saljagindima

var

 A: array [1..1000] of Integer;

 i, ik, s, c: Integer;

begin

 WriteLn ('Введите последовательность целых чисел, 0 для окончания ввода: ');

 i := 0;

 repeat

   i := i + 1;

   ReadLn (A [i]);

 until A [i] = 0;

 ik := i - 1;

 s := 0;

 c := 0;

 for i := 1 to ik do begin

   s := s + A [i];

   if (A [i] mod 5 = 0) or (A [i] mod 9 = 0) then

     c := c + 1;

 end;

 WriteLn;

 WriteLn ('Сумма чисел = ', s);

 WriteLn ('Количество чисел, кратрных 5 или 9 = ', c);

end.

matoksana

Этап 1

1. Разработка концепции:

возраст пользователя.

вид игры: развлекающая, развивающая, обучающая, комплексная.

2. Разработка адресных требований к игре:

к сценарию.

к игровой среде.

к графике игры.

3. Написание сценария:

создание сюжетной канвы с определением персонажей игры.

прописывание диалогов.

внесение в канву сценария игровых моментов (развлекающих, обучающих, развивающих).

прописывание речёвок и моментов ожидания действий пользователя.

проверка сценария на: удобство управления игрой, удобство перемещения в игровом поле, соответствие концепции и требованиям к данной игре; взаимное соответствие элементов сценария друг другу.

4. Разработка технических требований к игре и подготовка тех.задания.

5. Взаимодействие с разработчиками технической части игры:

передача сценария в разработку.

разработка визуальных образов персонажей и фонов игры.

стыковка пожеланий заказчика игры с возможностями разработчиков по организации игрового Озвучка персонажей, если в игре имеются говорящие персонажи.

6. Тестовая версия игры.

7. Подготовка второго этапа - итоги предварительной работы, обобщение опыта, план работы по доработке игры.

Виктория-Марина626

#include <iostream>

using namespace ::std;

int main()

{

   setlocale(LC_CTYPE , "rus");

   

   int n, i, j = 0, k = 0;

   double s = 0;

   cout << "Введите количество элементов: \n";

   cin >> n;

   float x;

   float *massiv = new float[n];

   if (!massiv)

   {

       cout << "Сбой программы!\n";

       system("pause");

        return 0;

   }

   cout << "Введите массив с " << ' ' << n << ' ' << "элементов\n";

   for (i = 0; i < n; i++)

       cin >> *(massiv + i);

   cout << "Заданный массив: " << endl;

   for (int i = 0; i < n; i++)

       

       cout << *(massiv + i) << ' ' << endl;

 

   for (i = 0; i<n; i++)

   {

       if (massiv[i]>0)

           k++;

   }

   cout << " Количество положительных элементов = " << k << '\n';

 

 

   for (i = 0; i<n; i++)

   {

       if (massiv[i] == 0) {

           j = massiv[i];

           x = i;

       }

   }

 

   for (i = x; i<n; i++)

       s += massiv[i];

 

   cout << "Сумма =" << s;

   float *massiv2 = new float[n];

   if (!massiv2)

   {

       cout << "Сбой программы !\n";

       system("pause");

       return 0;

   }

   for (i = 0; i < n; i++)

       if (massiv[i] <= 1)

       {

           massiv2[j] = massiv[i];

           j++;

       }

 

   for (i = 0; i < n; i++)

       if (fabs(massiv[i]) > 1)

       {

           massiv2[j] = massiv[i];

           j++;

       }

   cout << endl << "Отсортированный массив: " << endl;

   for (int j = 0; j < n; j++)

       cout << '\n' << massiv2[j] << ' ';

 

   delete[] massiv;

   delete[] massiv2;

   system("pause");

   return 0;

}

В работо не сомневайся.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая в последовательности целых чисел определяешь сумму чисел, а также количество чисел, кратных 5 или 9. программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается 0 (0-признак окончания ввода, не входит в последовательность количество чисел не превышает 1000. введённые числа по модулю не превышают 30 000
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Serdechnaya636
Yevgenii_Gurtovaya1532
mokeevahelena
besson89
Freelifecool797
volkovaekaterina303
valera850515
mariya
myxa120283
Valerii276
gulyaizmailova
naromanova
avdeevo
picassovrn
Irina_Nikolai