TrofimovAnastasiya828
?>

Напишите программу которая получает с клавиатуры натуральное число которое больше 1 и определяет простое оно или нет. для этого нужно делить число на все натуральные числа начиная с 2 пока не получится деление без остатка repeat и until

Информатика

Ответы

fancy-decor67

program simple_num;

var n:integer;


function simple(num:integer):boolean;

var count, i:integer;

   key:boolean;

begin

   count := 0;

   i := 1;

   repeat

       if num mod i = 0 then

           inc(count);

       inc(i);

   until (i > num);

   if count > 2 then

       key := false

   else key := true;

   simple := key;

end;


begin

   writeln('Введите натуральное число больше 1');

   readln(n);

   if n > 1 then

       if simple(n) then

           writeln('Число ',n, ' простое')

       else writeln('Число ',n, ' непростое')

   else writeln('введено число менее 1');

end.

andreykrutenko
Var     n, m, sum: integer;   begin     sum : = 0;     repeat     writeln('введите числ с которого начинается ряд');     readln(n);     writeln('введите число которым заканчивается ряд');     readln(m);     until n< m;       if odd(n) then n : = n + 1;     if odd(m) then m : = m - 1;     sum : = (n + m) * (m - n + 2) div 4;     writeln('сумма чётных чисел натурального ряда: ', sum); end.
galkar
Вот тебе простой вариант ришение задачи (коментар=пояснение)

PascalВыделить код

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16  program prg;  uses crt;  var  rez,chislo,min,max:integer;  begin  Write('Enter number =  ');readln(chislo);                 //zanosim 1 chislo  max:=chislo;                                              //v max ta min  min:=chislo;                                              //chtobu potom mu soukb sravnivat s drugimi chislamu  while (chislo<>0) do                                      //zapuskaem zikl poka mu ne napishem 0  begin   if (chislo>max)then max:=chislo;                         //sravnivaem s max   if (chislo<min) then min:=chislo;                        //sravnivaem s min   readln(chislo);                                          //snova pihem chislo   end;   rez:=(max-min);                                          //nahodim raznizy   writeln('max(',max,') - min(',min,') = ',rez);           //otvet end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу которая получает с клавиатуры натуральное число которое больше 1 и определяет простое оно или нет. для этого нужно делить число на все натуральные числа начиная с 2 пока не получится деление без остатка repeat и until
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

billl24
tsypant
vnolenev
fancy-decor67
КалюкМарасанов1026
lukur2005
adhotel
Олег1105
arinaunknown6867
fermproddk
MAXIM76748
info-mosbalkon
podenkovaev314
Кирьяков-Крикунов
ivanovk3599