Artyukhin545
?>

Дано целое число x номер дня недели. определить является, ли этот день выходным или рабочимсоставить программу)

Информатика

Ответы

Ирина
program paskal; var x:integer; begin writeln('Введите номер дня недели:'); readln(x); if x in [1..5] then begin writeln('Рабочий'); end; if x in [6..7] then begin writeln('Выходной'); end; end.
agrilandrussia
1)
Var
n,m,max,min:integer;
Begin
write('Введите число: ');
readln(n);
min:=9;   
max:=0;
while n>0 do 
begin 
m:=n mod 10; 
if m<min then min:=m; 
if m>max then max:=m; 
n:=n div 10; end;   
writeln('Максимальное число: ',max);   
writeln('Минимальное число: ',min);
End.
2)
var
i,count: integer;
n,s:string;
begin
writeln('Введите число: ');
readln(s);
writeln('Введите цифру: ');
readln(n);
for i:=1 to length(s) do
if(s[i]=n)then
count:=count+1;
writeln('Количество раз, когда встречается цифра = ',count);
end.
Владислав893
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a,b,c:real;
  Read(a,b,c); // не вводить одинаковых!
  if a>b then
    if a>c then // a > [b,c]
      if b>c then Writeln('Среднее - второе число')
      else Writeln('Среднее - третье число')
    else Writeln('Среднее - первое число')
  else
    if b>c then // b > [a,c]
      if a>c then Writeln('Среднее - первое число')
      else Writeln('Среднее - третье число')
    else Writeln('Среднее -  второе число')
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дано целое число x номер дня недели. определить является, ли этот день выходным или рабочимсоставить программу)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

fedotochkin8
Anatolevich-sergeevna
xeniagolovitinskaya4546
Khlistova1488
violettamakhina2537
Nadegdasb
vvb1383
ladykalmikova81
vitaldicky349
m79857860146895
irkm8
apioslk4533
TrofimovAnastasiya828
dumpler
vasilevam